summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-03 00:27:40 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-04 21:00:25 +0200
commit399da22815cf7dd43afe0846a6f0d6caa5f4d7f5 (patch)
tree215549c62c5a0d98817a3f51f1525cc986a74e93
parentdev-python/flask-debug: add Python 3.8 and 3.9 support (diff)
downloadgentoo-399da22815cf7dd43afe0846a6f0d6caa5f4d7f5.tar.gz
gentoo-399da22815cf7dd43afe0846a6f0d6caa5f4d7f5.tar.bz2
gentoo-399da22815cf7dd43afe0846a6f0d6caa5f4d7f5.zip
dev-python/flask-nav: add support for Python 3.8 and 3.9
Also switch to distutils_enable_* functions. Package-Manager: Portage-3.0.3, Repoman-2.3.23 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--dev-python/flask-nav/flask-nav-0.6-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/flask-nav/flask-nav-0.6-r2.ebuild b/dev-python/flask-nav/flask-nav-0.6-r2.ebuild
new file mode 100644
index 000000000000..75935b1a5538
--- /dev/null
+++ b/dev-python/flask-nav/flask-nav-0.6-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily create navigation for Flask applications."
+HOMEPAGE="https://pythonhosted.org/flask-nav/"
+# docs are missing from PyPI tarballs
+# https://github.com/mbr/flask-nav/pull/12
+SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/dominate[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/visitor[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/alabaster