summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-14 17:12:36 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-14 17:28:10 +0200
commit39a5fff3ec27a1d24b9d40fd5c4ab30c03953fdc (patch)
treeb335177cb8bd1770a7470d090c3a20aa45904b27
parentdev-python/python-gflags: Enable py3.12 (diff)
downloadgentoo-39a5fff3ec27a1d24b9d40fd5c4ab30c03953fdc.tar.gz
gentoo-39a5fff3ec27a1d24b9d40fd5c4ab30c03953fdc.tar.bz2
gentoo-39a5fff3ec27a1d24b9d40fd5c4ab30c03953fdc.zip
dev-python/python-poppler-qt5: Enable py3.12
Closes: https://bugs.gentoo.org/929503 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-poppler-qt5/Manifest2
-rw-r--r--dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild21
2 files changed, 15 insertions, 8 deletions
diff --git a/dev-python/python-poppler-qt5/Manifest b/dev-python/python-poppler-qt5/Manifest
index 90f4d7db1177..c6788136d272 100644
--- a/dev-python/python-poppler-qt5/Manifest
+++ b/dev-python/python-poppler-qt5/Manifest
@@ -1 +1 @@
-DIST python-poppler-qt5-21.3.0.tar.gz 25641 BLAKE2B 5937f1ddc1493bb1ef1d98b91dd8ccec4bd8c835956d84c8d7ce7a1cedcbe16854861e1f13825812e0f74c335020f0d74aad2d2bbc7a5780c6eb3ac77437f13b SHA512 cc942a860c2c999ff04fb0468b1556b0e23e7aa19a0185a39c5e903e717dca64bcbd51b8fe34b6885bd789cbf5cc1080c2ca1dcee30b3e69fa1721618e8db278
+DIST python-poppler-qt5-21.3.0.gh.tar.gz 25641 BLAKE2B 5937f1ddc1493bb1ef1d98b91dd8ccec4bd8c835956d84c8d7ce7a1cedcbe16854861e1f13825812e0f74c335020f0d74aad2d2bbc7a5780c6eb3ac77437f13b SHA512 cc942a860c2c999ff04fb0468b1556b0e23e7aa19a0185a39c5e903e717dca64bcbd51b8fe34b6885bd789cbf5cc1080c2ca1dcee30b3e69fa1721618e8db278
diff --git a/dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild b/dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild
index fe358ef69dac..cfb68d7001d9 100644
--- a/dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild
+++ b/dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild
@@ -1,28 +1,35 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=sip
-PYTHON_COMPAT=( python3_{9,10,11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 multiprocessing qmake-utils
DESCRIPTION="Python binding for libpoppler-qt5"
-HOMEPAGE="https://github.com/frescobaldi/python-poppler-qt5"
-SRC_URI="https://github.com/frescobaldi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://github.com/frescobaldi/python-poppler-qt5/
+ https://pypi.org/project/python-poppler-qt5/
+"
+SRC_URI="
+ https://github.com/frescobaldi/python-poppler-qt5/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-RDEPEND="
+DEPEND="
app-text/poppler[qt5]
dev-python/PyQt5[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}"
+RDEPEND="
+ ${DEPEND}
+"
src_configure() {
DISTUTILS_ARGS=(