summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-30 07:57:49 +0000
committerSam James <sam@gentoo.org>2022-12-30 07:57:49 +0000
commit39b68aa3e8f76e368e3f322c75a8f923d2fb3e7d (patch)
treeee81c0e994d729615ea7f47d9c4b09060917a533
parentdev-libs/libnl: force YACC as bison (diff)
downloadgentoo-39b68aa3.tar.gz
gentoo-39b68aa3.tar.bz2
gentoo-39b68aa3.zip
net-libs/libpcap: force LEX=flex
Already BDEPENDing on it... Closes: https://bugs.gentoo.org/884275 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-libs/libpcap/libpcap-1.10.1-r2.ebuild8
-rw-r--r--net-libs/libpcap/libpcap-9999.ebuild17
2 files changed, 18 insertions, 7 deletions
diff --git a/net-libs/libpcap/libpcap-1.10.1-r2.ebuild b/net-libs/libpcap/libpcap-1.10.1-r2.ebuild
index 6edb007ae109..bda001c29111 100644
--- a/net-libs/libpcap/libpcap-1.10.1-r2.ebuild
+++ b/net-libs/libpcap/libpcap-1.10.1-r2.ebuild
@@ -38,8 +38,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
BDEPEND="
- sys-devel/flex
app-alternatives/yacc
+ sys-devel/flex
dbus? ( virtual/pkgconfig )
"
@@ -70,8 +70,10 @@ src_prepare() {
}
multilib_src_configure() {
- ECONF_SOURCE="${S}" \
- econf \
+ # bug #884275
+ export LEX=flex
+
+ ECONF_SOURCE="${S}" econf \
$(use_enable bluetooth) \
$(use_enable dbus) \
$(use_enable rdma) \
diff --git a/net-libs/libpcap/libpcap-9999.ebuild b/net-libs/libpcap/libpcap-9999.ebuild
index ddd15be165fc..6f83d33095c3 100644
--- a/net-libs/libpcap/libpcap-9999.ebuild
+++ b/net-libs/libpcap/libpcap-9999.ebuild
@@ -25,7 +25,8 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="bluetooth dbus netlink rdma remote static-libs usb yydebug"
+IUSE="bluetooth dbus netlink rdma remote static-libs test usb yydebug"
+RESTRICT="!test? ( test )"
RDEPEND="
bluetooth? ( net-wireless/bluez:=[${MULTILIB_USEDEP}] )
@@ -37,8 +38,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
BDEPEND="
- sys-devel/flex
app-alternatives/yacc
+ sys-devel/flex
dbus? ( virtual/pkgconfig )
"
@@ -48,6 +49,7 @@ fi
PATCHES=(
"${FILESDIR}"/${PN}-1.10.0-usbmon.patch
+
"${FILESDIR}"/${PN}-1.10.1-pcap-config.patch
)
@@ -62,8 +64,10 @@ src_prepare() {
}
multilib_src_configure() {
- ECONF_SOURCE="${S}" \
- econf \
+ # bug #884275
+ export LEX=flex
+
+ ECONF_SOURCE="${S}" econf \
$(use_enable bluetooth) \
$(use_enable dbus) \
$(use_enable rdma) \
@@ -76,6 +80,11 @@ multilib_src_configure() {
multilib_src_compile() {
emake all shared
+ use test && emake testprogs
+}
+
+multilib_src_test() {
+ testprogs/findalldevstest || die
}
multilib_src_install_all() {