summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-09-06 14:58:19 +0200
committerJeroen Roovers <jer@gentoo.org>2019-09-06 15:03:04 +0200
commit39bb2ca05a54ea844822d22d9b3217ac5446a89e (patch)
treedcd6a5d6af1e0b86b9faeeca76b304aaf4ff86fc
parentapp-emacs/mediawiki: Bump to version 2.2.9. (diff)
downloadgentoo-39bb2ca0.tar.gz
gentoo-39bb2ca0.tar.bz2
gentoo-39bb2ca0.zip
net-analyzer/cacti-spine: Version 1.2.6
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.2.6.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index 0b6830808d58..b4ff81f2737d 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1,3 +1,4 @@
DIST cacti-spine-1.1.38.tar.gz 805437 BLAKE2B 32d934f54e00d83e9807dd194a7cacf8d5526c8e5b84c44ffad201c07edcb117f862266843552299fe04cc780575b9b2dc7129a106a20bd709cb82844ade7812 SHA512 5409a690e89fcc74e1e87e34e1918cab27d1243825955eb8256a92f8e9658f312345c66b338a4a07a0e38c94e3275131cb4e58fb70e7b59837c0e6c47746e45e
DIST cacti-spine-1.2.2.tar.gz 2310298 BLAKE2B 782fb21fda6acf06434c6e996863a235670970b19e5218624723df4736c388c2d9f00c1e3cc623dad7973bcbbe7ae5d4bbe89e366c1f47ce83eac9b416f88cb4 SHA512 ef2f839f7b247439a8576d49e311546cfd2346eea06cfb26b7a05d4757ae28334e6ed6ea00396027dc6c0c6e107121ed38f356ba62d8202003553fea3b5d139e
DIST cacti-spine-1.2.5.tar.gz 105494 BLAKE2B 1bd2f33cee841fb7b05a1a32d3d0d2824c36ccdc69fbf52c48cfe2d7bdbface4c1925261c8643c19addde90346c5ecdee547d8014705dc34800f59eab6ac248c SHA512 5bbf5f68e0d3477d43afee57bc86bfeb61a3ddaa18f7c0e5e0c2413bde6646bcd662d93e4c124daa6eaef5bca5843fb359b733c5189d9f43a34a14fba7f03682
+DIST cacti-spine-1.2.6.tar.gz 106592 BLAKE2B 4c7f92e1c1e6061689a5a18cc73326e38b1ed275d443069bf5bb6ad0edb9429b4946096db650d9af73b11ec51f1bc8728420a5084847b4d468b1e13341655ea3 SHA512 6659a3694c38704e266efda40893ed8e1bc1c52f3ae93a66ad219043408dd77bfdbde55191982ed3cebdffce1f49faf3e487fb926c680ea9b1c6dd379e1b53fc
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.2.6.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.2.6.ebuild
new file mode 100644
index 000000000000..8ca6122419f9
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.2.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="https://cacti.net/spine_info.php"
+SRC_URI="https://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libressl"
+
+CDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-analyzer/net-snmp:=
+ dev-db/mysql-connector-c:0=
+"
+DEPEND="
+ ${CDEPEND}
+ sys-apps/help2man
+"
+RDEPEND="
+ ${CDEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8d-ping.patch
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ dosbin spine
+
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+
+ doman spine.1
+ dodoc CHANGELOG
+}