summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-09-09 20:21:06 +0200
committerSebastian Pipping <sping@gentoo.org>2022-09-09 20:22:24 +0200
commit39c3c7982fb3768bf4f6a22f59f0282fb602d141 (patch)
treebd538c4c69c2279bbe721f17a531db6f9a03f2b1
parentdev-db/postgresql: 15_beta4 (diff)
downloadgentoo-39c3c798.tar.gz
gentoo-39c3c798.tar.bz2
gentoo-39c3c798.zip
app-text/nuspell: 5.1.1
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.30, Repoman-3.0.3
-rw-r--r--app-text/nuspell/Manifest1
-rw-r--r--app-text/nuspell/nuspell-5.1.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/nuspell/Manifest b/app-text/nuspell/Manifest
index a9821cff84af..b1cc477667ed 100644
--- a/app-text/nuspell/Manifest
+++ b/app-text/nuspell/Manifest
@@ -1 +1,2 @@
DIST nuspell-5.1.0.tar.gz 370368 BLAKE2B 67338fe79ddb98267e0c1efc575e47fc1a8f894cd09b6ada6c6a3f5e89b02fe3a81686b1ff1af73e28fd86437d0f115e04fd5f5aea1954c3da4414f25325ec46 SHA512 08ce776d224c66ba4bdd8cb22943741f30e8e5ba03396bfef1db598321c9b0f8814dacffcb52287b3b669426c7b08e2c1a40323341a9ff9768a7187002e1d77a
+DIST nuspell-5.1.1.tar.gz 370879 BLAKE2B b02126a00f266b0a4a2271a530ee1aeac3c42d8b0474b5e2f12afa401f9ecfdb37e2bb2a759e74e522679e850622d34f86a4d66e4f7d6572285de06803ec75d6 SHA512 c33a52e3603071d3281b7cdcfa42776cd7ecb998292939538e53e364cfff63227cf094cd88ee6072b8a857f5d85c984c359a16b480dd462dac9cfd602cfd6c2c
diff --git a/app-text/nuspell/nuspell-5.1.1.ebuild b/app-text/nuspell/nuspell-5.1.1.ebuild
new file mode 100644
index 000000000000..ce8325fe5270
--- /dev/null
+++ b/app-text/nuspell/nuspell-5.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Spell checker library and CLI for complex natural languages"
+HOMEPAGE="https://nuspell.github.io/ https://github.com/nuspell/nuspell"
+SRC_URI="https://github.com/nuspell/nuspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0/5" # due to libnuspell.so.5
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/icu-60"
+DEPEND="${RDEPEND}
+ doc? ( app-text/pandoc )
+ test? ( <dev-cpp/catch-3:0 )
+ "
+
+DOCS=( CHANGELOG.md )
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ rm -R external/Catch2/ || die
+ if ! use test ; then
+ rm -R external/hunspell/ || die
+ fi
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo 'Nuspell needs language packs and/or dictionaries to be of use'
+ einfo 'e.g. package app-dicts/myspell-en or one of its siblings.'
+ einfo
+ einfo 'Besides MySpell dictionaries, for other options please'
+ einfo 'see https://nuspell.github.io/#languages-and-users .'
+ einfo
+}