summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-06-11 09:22:57 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-11 13:44:21 +0200
commit39c6da575fe50434278780d6bc3ab7586acf895f (patch)
tree45e58991eda5e959049f3e65baee928ccf0bb82f
parentdev-embedded/esptool: drop 3.3.2 (diff)
downloadgentoo-39c6da575fe50434278780d6bc3ab7586acf895f.tar.gz
gentoo-39c6da575fe50434278780d6bc3ab7586acf895f.tar.bz2
gentoo-39c6da575fe50434278780d6bc3ab7586acf895f.zip
dev-python/pulsectl: Switch to media-libs/libpulse
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pulsectl/pulsectl-23.5.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pulsectl/pulsectl-23.5.2-r1.ebuild b/dev-python/pulsectl/pulsectl-23.5.2-r1.ebuild
new file mode 100644
index 000000000000..4ea5704860a8
--- /dev/null
+++ b/dev-python/pulsectl/pulsectl-23.5.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python high-level interface and ctypes-based bindings for PulseAudio (libpulse)"
+HOMEPAGE="
+ https://github.com/mk-fg/python-pulse-control/
+ https://pypi.org/project/pulsectl/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libpulse
+"
+BDEPEND="
+ test? (
+ media-sound/pulseaudio-daemon
+ )
+"
+
+distutils_enable_tests unittest