summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-08 18:53:55 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-08 19:47:49 +0200
commit39c7cfdd6782e219e4a2686a9b22aa557f96820a (patch)
tree0652f55e4606a8c4954635fd900d1d8d75161012
parentdev-python/msgpack: Remove old (diff)
downloadgentoo-39c7cfdd6782e219e4a2686a9b22aa557f96820a.tar.gz
gentoo-39c7cfdd6782e219e4a2686a9b22aa557f96820a.tar.bz2
gentoo-39c7cfdd6782e219e4a2686a9b22aa557f96820a.zip
x11-misc/qt5ct: Bump to 1.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--x11-misc/qt5ct/Manifest1
-rw-r--r--x11-misc/qt5ct/qt5ct-1.8.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/x11-misc/qt5ct/Manifest b/x11-misc/qt5ct/Manifest
index b3d7b7781d3d..da6c22026392 100644
--- a/x11-misc/qt5ct/Manifest
+++ b/x11-misc/qt5ct/Manifest
@@ -1 +1,2 @@
DIST qt5ct-1.7.tar.bz2 85464 BLAKE2B fc39d489a0e1e2cb8e0caeb587ea9dd434dca4adefcc788fe3936a6f7bbc3c55b22072915580e1b0376d0b37433b59e355e220f3dc280a0de2d2600a37df237a SHA512 97f1afc137e750abbb8c4e442cb6e09d2aa0c4979de2117ea644d484e1f7489bec144332814aae961bfaa5f8ac9ddf027c7a665274a65aef26fc4bf7c45610c0
+DIST qt5ct-1.8.tar.bz2 85945 BLAKE2B 0a882a076eb1013c4196e9067f7ed135b0f86c2850071de4945bb17053618a605ca412fbc1c7a87a6e00ee051f4fb5f0d31754490aa51abe472c72a6918088c9 SHA512 5417850fb2bad4faaed59c8af61bec04c1ee7fefe8495286571e257b2f68cd417d36439c66fcfac28bb735c753a4ca4cec327b74e97e5ce8c2d4e36b3e4fba28
diff --git a/x11-misc/qt5ct/qt5ct-1.8.ebuild b/x11-misc/qt5ct/qt5ct-1.8.ebuild
new file mode 100644
index 000000000000..dac5f4a047cf
--- /dev/null
+++ b/x11-misc/qt5ct/qt5ct-1.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt5 configuration tool, similar to qtconfig for Qt4"
+HOMEPAGE="https://sourceforge.net/projects/qt5ct/"
+SRC_URI="https://download.sourceforge.net/qt5ct/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=[dbus]
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ dev-qt/qtpaths:5
+"
+
+src_install() {
+ cmake_src_install
+
+ newenvd - 98qt5ct <<< 'QT_QPA_PLATFORMTHEME=qt5ct'
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ ewarn "qt5ct configuration won't be applied to the currently running sessions."
+ ewarn "Please relogin."
+ fi
+ if ! has_version 'dev-qt/qtsvg:5'; then
+ elog
+ elog "For SVG icon themes, please install 'dev-qt/qtsvg:5'."
+ elog
+ fi
+}