summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-14 17:07:19 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-14 18:11:04 +0200
commit39d2d264495ba468a09be3a2f2e56a19c2f1a59c (patch)
tree5c59defaf294894bfaada5a63f606295e5da29d4
parentdev-python/semver: Bump to 3.0.1 (diff)
downloadgentoo-39d2d264495ba468a09be3a2f2e56a19c2f1a59c.tar.gz
gentoo-39d2d264495ba468a09be3a2f2e56a19c2f1a59c.tar.bz2
gentoo-39d2d264495ba468a09be3a2f2e56a19c2f1a59c.zip
dev-python/django-cors-headers: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/django-cors-headers/Manifest1
-rw-r--r--dev-python/django-cors-headers/django-cors-headers-4.1.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/django-cors-headers/Manifest b/dev-python/django-cors-headers/Manifest
index 0bbfe06848fe..75103948c692 100644
--- a/dev-python/django-cors-headers/Manifest
+++ b/dev-python/django-cors-headers/Manifest
@@ -1,2 +1,3 @@
DIST django-cors-headers-3.14.0.gh.tar.gz 29634 BLAKE2B 08ec6811b8608feecbdaadcc6ce220b1574a4bf16823f939f93eda4ece9df0430b015edc1d0909b980996ff143e036858ca81f524e8d270846881a9c0af25fac SHA512 5ff390bd2fba1b3dff3cea08b10021d0fd100497000b2eaef788fe32c1b8584f1954e470f4aa15cbcf9e4342265633a658b8736de08962bfe0ea9e2068521379
DIST django-cors-headers-4.0.0.gh.tar.gz 29641 BLAKE2B 20ff68bfb02d6992777967db35696a33afb91b264be1ebb3b67c15a9e2a51e0df948dae78b107bce16bc6eab2679d3ba910a9be89c8d7d137b64f7997fd2a400 SHA512 250ff2f9876d1d965611f495e0b67d4f93da9f05e0804bb8c02ec8390923eb1b7c775e4c76df8acf7d43d0f1401267f3795bc29fa7c5c8936a7aee1dae7336e5
+DIST django-cors-headers-4.1.0.gh.tar.gz 30733 BLAKE2B f3214008c51d656022c58bd0eb012200e07a29ec4052a4d3b75b2c52b4aee0e96b3ef8b30857dddc528cda609f691f0a9ef4f791837d1962ab561f42b840f814 SHA512 a4a1a39ab658968d5384a40a6aaf2e5c9a9047e43edc2ef7d4b9ea82a4e6cac6e69eb5e0b3736b9731442ff4efbe249ee56c7a3d05808e3fa0b45f6dee25999a
diff --git a/dev-python/django-cors-headers/django-cors-headers-4.1.0.ebuild b/dev-python/django-cors-headers/django-cors-headers-4.1.0.ebuild
new file mode 100644
index 000000000000..f88ae7b6888a
--- /dev/null
+++ b/dev-python/django-cors-headers/django-cors-headers-4.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django App that adds CORS (Cross-Origin Resource Sharing) headers to responses"
+HOMEPAGE="
+ https://github.com/adamchainz/django-cors-headers/
+ https://pypi.org/project/django-cors-headers/
+"
+SRC_URI="
+ https://github.com/adamchainz/django-cors-headers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest