summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-11-14 22:11:14 -0500
committerTim Harder <radhermit@gentoo.org>2017-11-14 22:32:03 -0500
commit39ec2c7e0867870e4c68cabc4e48e30be3c12be6 (patch)
tree4831ab2e6a97156b41ebdd72b81816f6867ad545
parentdev-python/hypothesis: version bump to 3.37.0 (diff)
downloadgentoo-39ec2c7e.tar.gz
gentoo-39ec2c7e.tar.bz2
gentoo-39ec2c7e.zip
dev-python/pycairo: version bump to 1.15.4
-rw-r--r--dev-python/pycairo/Manifest1
-rw-r--r--dev-python/pycairo/pycairo-1.15.4.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/pycairo/Manifest b/dev-python/pycairo/Manifest
index 5577f0d07b88..da1ce22f7ed4 100644
--- a/dev-python/pycairo/Manifest
+++ b/dev-python/pycairo/Manifest
@@ -2,3 +2,4 @@ DIST py2cairo-1.10.0.tar.bz2 402070 SHA256 d30439f06c2ec1a39e27464c6c828b6eface3
DIST pycairo-1.10.0-gentoo-patchset.tar.bz2 9669 SHA256 31b5aef32b5d2fb3d8e1c6f9629e6d78e6b3928a3a1c7e44af2120f38490d00e SHA512 c367a7d8fa771ac900ca3363cb7dfd50de045cf67c73c6e552d05018c6933b13dd5660b033be59e1acf8af79f16253a8e56aaa3f135a262a8148711ae8b7a587 WHIRLPOOL 65890911ee35568fceaa5146bf5e4718011eb2f606dc6c180e7ce612fe2351488c7ad2ea2322ec1ca55eb0f8b6f4fb3fb759152be525d20f80922d707108bc9e
DIST pycairo-1.10.0.tar.bz2 246556 SHA256 9aa4078e7eb5be583aeabbe8d87172797717f95e8c4338f0d4a17b683a7253be SHA512 a03db6f04cea504985f390b0734042390f491f32ae2bee1299dabbafd369fde36bb506ebb941d22bbc11b0d008c4f758baeacf309a7336880529455092db829f WHIRLPOOL e779d56d67ef18bbd052d81acb38d8b610ca4bbf787f4b0e3982633de55ff54d6dfa3e5ce1957321fba09f0ec2d12ce12057335de9d5ff3f84c2bc0530415e76
DIST pycairo-1.15.3.tar.gz 177056 SHA256 8642e36cef66acbfc02760d2b40c716f5f183d073fb063ba28fd29a14044719d SHA512 1fc75d193eacb976f2e5a594aa07409a0f80ccb21921065c1794961143785eed48be1966d2d2d3e2d0428f9b4e956994dd851d21f3c3cb91fbc27b007a901ce8 WHIRLPOOL e9248366c8eb541bc70ad73c9c6eea995a2527d189584a1ec6f6b835fdeae57d1aa63e2deaa9f790042d0670e7d07af8867b111ac107b53befd354c3cfc70ca1
+DIST pycairo-1.15.4.tar.gz 178436 SHA256 ee4c3068c048230e5ce74bb8994a024711129bde1af1d76e3276c7acd81c4357 SHA512 7e785d23393a8d0c5aca9a4440eb64b0eca9a60c1a18b0dc8452edd6de9422c743d082530387bcbedd34d52377d0892ad395998e9467ba08e22c318684cbee34 WHIRLPOOL d7d9e72bfd33f144423a39ed410251351fd1e32b432fe321d30ff384f05946e353d3159a6c9d8e79b6eb3ff34911bc473222ffe37816a9a2981d1e8e6bc88be3
diff --git a/dev-python/pycairo/pycairo-1.15.4.ebuild b/dev-python/pycairo/pycairo-1.15.4.ebuild
new file mode 100644
index 000000000000..77146c084dc0
--- /dev/null
+++ b/dev-python/pycairo/pycairo-1.15.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the cairo library"
+HOMEPAGE="https://www.cairographics.org/pycairo/ https://github.com/pygobject/pycairo"
+SRC_URI="https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples test xcb"
+
+# Note: xpyb is used as the C header, not Python modules
+RDEPEND="
+ >=x11-libs/cairo-1.13.1[svg,xcb?]
+"
+DEPEND="${RDEPEND}
+ xcb? ( $(python_gen_cond_dep '>=x11-libs/xpyb-1.3' 'python2*') )
+ doc? ( dev-python/sphinx )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Fix pkgconfig path
+ sed -i -e "/libdir =/s:\"lib\":\"$(get_libdir)\":" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local enable_xpyb
+ python_is_python3 || enable_xpyb=$(usex xcb "--enable-xpyb" "")
+
+ esetup.py build ${enable_xpyb}
+}
+
+python_compile_all() {
+ use doc && emake -C docs
+}
+
+python_test() {
+ local enable_xpyb
+ python_is_python3 || enable_xpyb=$(usex xcb "--enable-xpyb" "")
+
+ esetup.py test ${enable_xpyb}
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/. )
+
+ if use examples; then
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}