summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-20 07:14:15 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-20 07:40:43 +0200
commit39f747e9fa3b2df5c439c69e69b890de3316df4a (patch)
tree5003fbe1cf1033f6ec950b062954a9fd7d7c4add
parentdev-python/dask-expr: Bump to 1.0.12 (diff)
downloadgentoo-39f747e9fa3b2df5c439c69e69b890de3316df4a.tar.gz
gentoo-39f747e9fa3b2df5c439c69e69b890de3316df4a.tar.bz2
gentoo-39f747e9fa3b2df5c439c69e69b890de3316df4a.zip
dev-python/fakeredis: Bump to 2.22.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fakeredis/Manifest1
-rw-r--r--dev-python/fakeredis/fakeredis-2.22.0.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index 4d773610816d..6b253b4700b4 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1 +1,2 @@
DIST fakeredis-2.21.3.tar.gz 129013 BLAKE2B 9c56fadc1090cc886fe08b53404c21b1659f4f9c9f5c3c168f02a7ac71e7e660924aec8ad82dbc18d8c2c11245b4548e71ec68d5e83a0a9fd4e5503b85be0cc0 SHA512 aade7596729b7100ef58a2a87cbd011fd4e60970c0c310ca70748e03b787fd3e0ef6d5c54739e91c839f9451a12ec029d441e3cfb4ed3238425b2cce526d8030
+DIST fakeredis-2.22.0.tar.gz 130074 BLAKE2B 28ccc177c8f2d47515ff91834901b8fdf9559b83b1e7665101b5f17e57d65a3c820af6be21251257f35a7db858c22fac3395cfb550b724e020e96778ad380008 SHA512 a533f26c2a4289b1b4d398ee426f44c93f01a4aac0dc841854bf94674d7e0738fde38ea896280d4e83bf16041dba505db13e3fa3837a912dc872b1d36c05cc6e
diff --git a/dev-python/fakeredis/fakeredis-2.22.0.ebuild b/dev-python/fakeredis/fakeredis-2.22.0.ebuild
new file mode 100644
index 000000000000..916767f1330c
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-2.22.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/cunla/fakeredis-py/
+ https://pypi.org/project/fakeredis/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2[${PYTHON_USEDEP}]
+ <dev-python/sortedcontainers-3[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # also lupa
+ test/test_aioredis2.py::test_failed_script_error
+ # TODO
+ "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
+ "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_channels[StrictRedis]"
+ test/test_mixins/test_set_commands.py::test_smismember_wrong_type
+ # new redis-server?
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_shardnumsub[StrictRedis]"
+ # json ext
+ test/test_json/test_json.py
+ test/test_json/test_json_arr_commands.py
+ )
+ local EPYTEST_IGNORE=(
+ # these tests fail a lot...
+ test/test_hypothesis.py
+ )
+ local args=(
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+ # Note: this package is not xdist-friendly
+ epytest "${args[@]}"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}