summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-04-11 14:19:16 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-04-11 16:17:02 +0200
commit3a27e719bf6756f3e4b39140880e1da7df3afe9d (patch)
tree9681f65661a0eac3a980a01b5eff9515281ef4d6
parentapp-emacs/swiper: bump to 0.14.0 (diff)
downloadgentoo-3a27e719bf6756f3e4b39140880e1da7df3afe9d.tar.gz
gentoo-3a27e719bf6756f3e4b39140880e1da7df3afe9d.tar.bz2
gentoo-3a27e719bf6756f3e4b39140880e1da7df3afe9d.zip
app-emacs/counsel: bump to 0.14.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/counsel/Manifest1
-rw-r--r--app-emacs/counsel/counsel-0.14.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/counsel/Manifest b/app-emacs/counsel/Manifest
index 01a00abc7179..244180e94d8e 100644
--- a/app-emacs/counsel/Manifest
+++ b/app-emacs/counsel/Manifest
@@ -1 +1,2 @@
DIST swiper-0.13.4.tar.gz 245190 BLAKE2B c4da021b92fcedfec39cc60f670c97e4a421b8d4aef8183f50c4872bed835db79884cff113f58cf21dfa7ce33158218aa0cf25d72fc0081dc1c24a3b4376c60e SHA512 bf096a13f675f87af6ea68c974455896b64921ca4d7880c9ccc444aa3cea7c7e04c61be5deb2fd57d0568ff4d86f96ffcf94494b55d84d7a9f647f49b69aec9a
+DIST swiper-0.14.0.tar.gz 249820 BLAKE2B 9184e66f910b9f7c401c9a5433b5915c393ece7711858c3f844d8afcbc13fa76039173b2ecd50bbaff586ff7596fd95e46e550a4282763e385f064d2e2103978 SHA512 e87fa2159d1541afdaa08e33584480cbeba75df15235bf57d4c8f6292b91be7e2a316e931c3f4d823da5fbf23d987ded293a433824af04357de231d26adfeeb1
diff --git a/app-emacs/counsel/counsel-0.14.0.ebuild b/app-emacs/counsel/counsel-0.14.0.ebuild
new file mode 100644
index 000000000000..4b056723c545
--- /dev/null
+++ b/app-emacs/counsel/counsel-0.14.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Versions of common Emacs commands customized to make the best use of ivy"
+HOMEPAGE="https://github.com/abo-abo/swiper/"
+SRC_URI="https://github.com/abo-abo/swiper/archive/${PV}.tar.gz
+ -> swiper-${PV}.tar.gz"
+S="${WORKDIR}"/swiper-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Ivy, Swiper and Counsel tests are performed in app-emacs/ivy
+
+RDEPEND="
+ >=app-emacs/ivy-${PV}
+ >=app-emacs/swiper-${PV}
+"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile ${PN}.el
+}
+
+src_install() {
+ elisp-install ${PN} ${PN}.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}