summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 06:00:24 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:48:14 -0400
commit3a42003924c50f31c331265b58e9881e92696980 (patch)
tree66c0edaff11c4f0a09bb57db1060ed28a77fc87e
parentx11-misc/xtrlock: force gcc -E for imake's generation (diff)
downloadgentoo-3a420039.tar.gz
gentoo-3a420039.tar.bz2
gentoo-3a420039.zip
x11-plugins/wmnet: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Can still use clang & friends for everything else. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-plugins/wmnet/wmnet-1.06-r2.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/x11-plugins/wmnet/wmnet-1.06-r2.ebuild b/x11-plugins/wmnet/wmnet-1.06-r2.ebuild
index 1b2ce83086b5..21e339edf295 100644
--- a/x11-plugins/wmnet/wmnet-1.06-r2.ebuild
+++ b/x11-plugins/wmnet/wmnet-1.06-r2.ebuild
@@ -18,17 +18,18 @@ IUSE=""
RDEPEND="x11-libs/libX11
x11-libs/libXext"
DEPEND="${RDEPEND}
+ x11-base/xorg-proto
elibc_musl? ( net-libs/ppp-defs )"
BDEPEND="
- x11-base/xorg-proto
- >=x11-misc/imake-1.0.8-r1
- app-text/rman"
+ app-text/rman
+ sys-devel/gcc
+ >=x11-misc/imake-1.0.8-r1"
PATCHES=( "${WORKDIR}"/${P}-misc.patch )
src_configure() {
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die "xmkmf failed"
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die "xmkmf failed"
}
src_compile() {