summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-01-14 19:56:41 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-14 20:34:27 -0500
commit3a4de1a00cc1f5de3feb0956bccf7b5cd908f921 (patch)
treefaa5b717dd018fb7986202ce0df8704c909dbf47
parentapp-text/dvisvgm: fix other dependencies (diff)
downloadgentoo-3a4de1a00cc1f5de3feb0956bccf7b5cd908f921.tar.gz
gentoo-3a4de1a00cc1f5de3feb0956bccf7b5cd908f921.tar.bz2
gentoo-3a4de1a00cc1f5de3feb0956bccf7b5cd908f921.zip
media-libs/mesa: Always specify -Dplatforms=...
Otherwise it will default to -Dplatforms=auto, which includes Wayland. Many thanks to Jan Burgmeier for debugging the issue and providing the fix. Closes: https://bugs.gentoo.org/759139 Closes: https://bugs.gentoo.org/759319 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/mesa/mesa-20.2.4.ebuild2
-rw-r--r--media-libs/mesa/mesa-20.2.6.ebuild2
-rw-r--r--media-libs/mesa/mesa-20.3.2.ebuild2
-rw-r--r--media-libs/mesa/mesa-9999.ebuild2
4 files changed, 4 insertions, 4 deletions
diff --git a/media-libs/mesa/mesa-20.2.4.ebuild b/media-libs/mesa/mesa-20.2.4.ebuild
index ca0dfceda9d0..a9abb722e3fc 100644
--- a/media-libs/mesa/mesa-20.2.4.ebuild
+++ b/media-libs/mesa/mesa-20.2.4.ebuild
@@ -369,7 +369,7 @@ multilib_src_configure() {
local platforms
use X && platforms+="x11"
use wayland && platforms+=",wayland"
- [[ -n $platforms ]] && emesonargs+=(-Dplatforms=${platforms#,})
+ emesonargs+=(-Dplatforms=${platforms#,})
if use X || use egl; then
emesonargs+=(-Dglvnd=true)
diff --git a/media-libs/mesa/mesa-20.2.6.ebuild b/media-libs/mesa/mesa-20.2.6.ebuild
index 87cd61434798..3a059a995dd4 100644
--- a/media-libs/mesa/mesa-20.2.6.ebuild
+++ b/media-libs/mesa/mesa-20.2.6.ebuild
@@ -369,7 +369,7 @@ multilib_src_configure() {
local platforms
use X && platforms+="x11"
use wayland && platforms+=",wayland"
- [[ -n $platforms ]] && emesonargs+=(-Dplatforms=${platforms#,})
+ emesonargs+=(-Dplatforms=${platforms#,})
if use X || use egl; then
emesonargs+=(-Dglvnd=true)
diff --git a/media-libs/mesa/mesa-20.3.2.ebuild b/media-libs/mesa/mesa-20.3.2.ebuild
index 4a9d566b07cd..3a23ce15ad2c 100644
--- a/media-libs/mesa/mesa-20.3.2.ebuild
+++ b/media-libs/mesa/mesa-20.3.2.ebuild
@@ -370,7 +370,7 @@ multilib_src_configure() {
local platforms
use X && platforms+="x11"
use wayland && platforms+=",wayland"
- [[ -n $platforms ]] && emesonargs+=(-Dplatforms=${platforms#,})
+ emesonargs+=(-Dplatforms=${platforms#,})
if use X || use egl; then
emesonargs+=(-Dglvnd=true)
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 152e9ea51a87..1a2ca6e33b86 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -374,7 +374,7 @@ multilib_src_configure() {
local platforms
use X && platforms+="x11"
use wayland && platforms+=",wayland"
- [[ -n $platforms ]] && emesonargs+=(-Dplatforms=${platforms#,})
+ emesonargs+=(-Dplatforms=${platforms#,})
if use X || use egl; then
emesonargs+=(-Dglvnd=true)