summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-05 09:06:37 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-05 10:27:15 +0200
commit3a5d17b093eb6c8df4ba508848e1dd36acd7dd52 (patch)
treea1ac712578b891547061bf85d947c5c5c52aede5
parentdev-python/apipkg: Bump to 2.0.1 (diff)
downloadgentoo-3a5d17b0.tar.gz
gentoo-3a5d17b0.tar.bz2
gentoo-3a5d17b0.zip
dev-python/wrapt: Bump to 1.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/wrapt/Manifest1
-rw-r--r--dev-python/wrapt/wrapt-1.13.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/wrapt/Manifest b/dev-python/wrapt/Manifest
index 00c18787cd5b..ab3ff40f1be4 100644
--- a/dev-python/wrapt/Manifest
+++ b/dev-python/wrapt/Manifest
@@ -1 +1,2 @@
DIST wrapt-1.12.1.tar.gz 126750 BLAKE2B 92aba2d400aa626445be68fdda2831132e1c341a2f20065b3d7071a2ebc174cb9de7e6a20a8375360cf7df181881fd20b7b2f70dbfdf533e8823982eeaa722f5 SHA512 33e964cb3aa2437bc7d084a98f622f7c5c8c719d97806796ae0317d35130bdb2679a9dd87be7077e2cae1eb32b65d152349fa7cc138cb392d5999cbfdcecc9ac
+DIST wrapt-1.13.1.tar.gz 130138 BLAKE2B bc9a0238a4e16f36e83a6fd81e94d5a257e27e0d5864dc98ba4036f16c3cd92b971e9eddf8193afd13b5afe82ac4f83d50e66f8bedfcd0068ce53f162f4f7ac5 SHA512 a5d7d9013e975261608563fc86b92dd9d455b9efe5f5a79800d317438317f86d59b5678cd4c053832aad2e35dfc08d75b16ed456564cfcbb6541a12a1741352f
diff --git a/dev-python/wrapt/wrapt-1.13.1.ebuild b/dev-python/wrapt/wrapt-1.13.1.ebuild
new file mode 100644
index 000000000000..01eb043f35e0
--- /dev/null
+++ b/dev-python/wrapt/wrapt-1.13.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Module for decorators, wrappers and monkey patching"
+HOMEPAGE="https://github.com/GrahamDumpleton/wrapt"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+
+python_compile() {
+ local WRAPT_EXTENSIONS=true
+
+ distutils-r1_python_compile
+}