summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-12 06:29:33 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-12 07:59:32 -0400
commit3a6dcb558251f3055224e65506ccce0ee55dc96d (patch)
tree677432ad102521ddbc820fad8bc0b72beb1cf403
parentdev-qt/qtimageformats: add 6.7.0_rc (diff)
downloadgentoo-3a6dcb558251f3055224e65506ccce0ee55dc96d.tar.gz
gentoo-3a6dcb558251f3055224e65506ccce0ee55dc96d.tar.bz2
gentoo-3a6dcb558251f3055224e65506ccce0ee55dc96d.zip
dev-qt/qtlocation: add 6.7.0_rc
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-6.7.0_rc.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index 36c1e901ea5e..118a982f8bae 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,4 +1,5 @@
DIST qtlocation-5.15.11-patchset.tar.xz 4796 BLAKE2B dcfa75bd3fb2e9069e1a530c27e2b4e9ac921fcf0ccb712f0894375b575ba25103948c6e5b85b56a8f9c9f2d7edf7df8e38501e93356e69f060b577a04c2d221 SHA512 14bd2864abc6f446dc4fbac03548cb42305685b46db757d856360780144095a021130bc0ebf1d07a516dc7991dc0cfbf733bd0ef6be58237bc15822c21af1d0b
DIST qtlocation-everywhere-opensource-src-5.15.12.tar.xz 6553488 BLAKE2B e9cab8e6f62cc1cfc6586fa4a1b252bce915479fca5f9fbeac66a2494d77047af4af1ba840786799637edae3af7c6d2000f640af018548cfcd7bd624c6a31b15 SHA512 c480762cea2cd1a00e6061bab05c402d5aab2d12e7decebcd606c930d2029a93f2a46f8edbb188b73c7cdcad473b03c15037ea10e0b3538de0a99b1d7d7fb333
DIST qtlocation-everywhere-src-6.6.2.tar.xz 3028592 BLAKE2B 060dbe1d4ea3d761900f1f2e8eff0ae255b1b75edc8c23e1ce04d6d3a7b3ea278b9121d417e347bc589a5445b35f52db5447de0f0d1154d8859bfe83d4d5e7da SHA512 a2c4b9d9fb3b3675d25d3e7abeb8eec42f5998a9b275648a355df61c7d21258fb6bf5ecefeb635bab1a37f3382fc71b588a05eafc1bd7b57580c0f9999c9f1cd
+DIST qtlocation-everywhere-src-6.7.0-rc.tar.xz 3166060 BLAKE2B eb505b6af66934257af552f2f7ff203141369743a85e4b416975a343fad356007c0fa740d5b717f16c17850221a2b010949dc1ccc9664f727debd9f3f004c58c SHA512 b979874a6565d5c5e066d21f0106a8c28adb6582bd642543a2ae55a57e314aeb2a8d996383446421509afeaba11bf5d8236ceb32239f7362a031a741f2cb4ec5
DIST qtlocation-mapboxgl-5.15.12-4c88f2c0.tar.gz 3726387 BLAKE2B e9b818505ace86516262d1407450c14be82122bb91363a57708795844089371ac7d511a857f713c7cb4e6f8b54867aab0bc5dcdb9c49aa28aa3f8363271378e0 SHA512 e4d9133db892fd8b7b1bcf584bf7dae30c0f0353f3b0a696a6cabc9485067f262d42554b583640521734498572e5480b5e8d0143d5be47bb92077f3192fefa4d
diff --git a/dev-qt/qtlocation/qtlocation-6.7.0_rc.ebuild b/dev-qt/qtlocation/qtlocation-6.7.0_rc.ebuild
new file mode 100644
index 000000000000..112102c1365c
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-6.7.0_rc.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ ~dev-qt/qtdeclarative-${PV}:6
+ ~dev-qt/qtpositioning-${PV}:6[qml]
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # ignores QML_IMPORT_PATH (unlike other tests) and looks in
+ # the missing builddir/qml, skip rather than work around
+ tst_declarative_ui
+)
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ local delete=( # sigh
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*TestGeoServicePlugin*.cmake
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*UnsupportedPlacesGeoServicePlugin*.cmake
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Qml/QmlPlugins/*declarative_location_test*.cmake
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_geocodingplugin.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_placesplugin_unsupported.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_qmltestplugin.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_routingplugin.so
+ "${D}${QT6_QMLDIR}"/QtLocation/Test
+ )
+ # using -f given not tracking which tests may be skipped or not
+ rm -rf -- "${delete[@]}" || die
+ fi
+}