summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-03 07:39:02 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-03 08:02:17 +0200
commit3a6dffbca06071b5233061e55ba1e528741e5614 (patch)
tree5d45bd6056e16424455b0ff7dd04bbadeba23f1a
parentdev-python/dask-expr: Bump to 1.0.9 (diff)
downloadgentoo-3a6dffbca06071b5233061e55ba1e528741e5614.tar.gz
gentoo-3a6dffbca06071b5233061e55ba1e528741e5614.tar.bz2
gentoo-3a6dffbca06071b5233061e55ba1e528741e5614.zip
dev-python/pytest-order: Bump to 1.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-order/Manifest1
-rw-r--r--dev-python/pytest-order/pytest-order-1.2.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pytest-order/Manifest b/dev-python/pytest-order/Manifest
index 07ad700037d5..13647a70ed85 100644
--- a/dev-python/pytest-order/Manifest
+++ b/dev-python/pytest-order/Manifest
@@ -1 +1,2 @@
DIST pytest-order-1.2.0.tar.gz 44307 BLAKE2B 82611b713c9ae064c41e966d503c649c130d5a1df520594f513e9ab3d1cf6890fba65afa860822aedcee1a95617d3cd9010f5189d158cd76b2a4b9d25dd7d916 SHA512 f615dd57546e90c614af35fd79e7e579d48a5e709af3324f476d347e191606b81698bde619a2d0c7181e6f3b1a3c41121c1b06b5de87e66ac2caa77b5ea11ad9
+DIST pytest-order-1.2.1.tar.gz 44726 BLAKE2B b0365a6c7d420e5997ca67fc3de3d46a02a085f024ba2777c480f4c9da7e90ac3dd3b533d67e43934429f3a1ace1725171c56ad59eeb598c06bbe4dbbc5f71e0 SHA512 2ea89f05e6dcf82a6df596feeb1e25b634e48c4c6219b5320b662e88b5ee2473062f3bf1d38696dac2e045fdf51a118b7907c4a06a90e6e256b4d21bd156be18
diff --git a/dev-python/pytest-order/pytest-order-1.2.1.ebuild b/dev-python/pytest-order/pytest-order-1.2.1.ebuild
new file mode 100644
index 000000000000..f861ccc1aacd
--- /dev/null
+++ b/dev-python/pytest-order/pytest-order-1.2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin to run your tests in a specific order"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-order/
+ https://pypi.org/project/pytest-order/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-6.4.2[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # these require pytest-dependency
+ tests/test_dependency.py::test_order_dependencies_no_auto_mark
+ tests/test_dependency.py::test_order_dependencies_auto_mark
+ tests/test_order_group_scope_dep.py::test_class_group_scope_module_scope
+ tests/test_order_group_scope_named_dep.py::test_class_group_scope_module_scope
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_order.plugin,xdist.plugin,pytest_mock
+ epytest
+}