summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-24 12:00:02 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-24 12:01:07 +0200
commit3a6ed441813bbf8a10a6fd9fb93fc87e6cf9284a (patch)
treec6507a10dd663f93ae00969bee6ef8cdfecacf25
parentgames-action/minecraft-launcher: drop 1121 (diff)
downloadgentoo-3a6ed441.tar.gz
gentoo-3a6ed441.tar.bz2
gentoo-3a6ed441.zip
net-im/rocketchat-desktop-bin: add 3.8.8
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.8.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index 877f346ea074..434219909aad 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.8.7-linux-x86_64.rpm 62302012 BLAKE2B 2e5b36191abcb783e126e92bc608716efc910151484399cbbaf2fe0837fe8a40eb5c84b71e33052c5a950adfa0851d30be2e964754b08f3a9f3754169c5dc169 SHA512 833abf90425b5f9d0feb28acba4559d8d410ef2f5276b03fac8c781b9eab3ae7e0eebd613bc84e28a0dfa6005778a9afd91d528b6fa67ab825564e98241548c6
+DIST rocketchat-3.8.8-linux-x86_64.rpm 63234044 BLAKE2B a5ded5fb4e1e46be69888ff33090e9f6602ea7080d7313fedb7d20de2d55aadbfb69127d8deb9dae8262cde1856e98c91ef61f65a89374cd45aa7b81753ddc35 SHA512 de7c8957ec1d870d25a9fa6af7fd5da54c6609dd953a3c2dd4c811080d880915a9a95f7d674d3e1d6f11fd423f445173a029bd4d1f605107e14a168c6dc7e20f
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.8.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.8.ebuild
new file mode 100644
index 000000000000..d604e2f82db7
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.8.ebuild
@@ -0,0 +1,102 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHROMIUM_LANGS="
+ af am ar bg bn ca cs da de el en-GB en-US es es-419 et fa fi fil fr gu he hi
+ hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv
+ sw ta te th tr ur uk vi zh-CN zh-TW
+"
+
+inherit chromium-2 desktop rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}-linux-x86_64.rpm"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+# Electron bundles a bunch of things
+LICENSE="
+ MIT BSD BSD-2 BSD-4 AFL-2.1 Apache-2.0 Ms-PL GPL-2 LGPL-2.1 APSL-2
+ unRAR OFL CC-BY-SA-3.0 MPL-2.0 android public-domain all-rights-reserved
+"
+SLOT="0"
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/Rocket.Chat/*"
+
+pkg_pretend() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_prepare() {
+ default
+ # cleanup languages
+ pushd "opt/Rocket.Chat/locales" || die
+ chromium_remove_language_paks
+ popd || die
+}
+
+src_configure() {
+ chromium_suid_sandbox_check_kernel_config
+ default
+}
+
+src_install() {
+ for size in {16,32,48,64,128,256,512}; do
+ doicon -s ${size} "usr/share/icons/hicolor/${size}x${size}/apps/rocketchat-desktop.png"
+ done
+
+ domenu usr/share/applications/rocketchat-desktop.desktop
+
+ local DESTDIR="/opt/Rocket.Chat"
+ pushd "opt/Rocket.Chat" || die
+
+ exeinto "${DESTDIR}"
+ doexe chrome-sandbox rocketchat-desktop *.so*
+
+ insinto "${DESTDIR}"
+ doins *.pak *.bin *.json *.dat
+ insopts -m0755
+ doins -r locales resources
+
+ # Chrome-sandbox requires the setuid bit to be specifically set.
+ # see https://github.com/electron/electron/issues/17972
+ fperms 4755 "${DESTDIR}"/chrome-sandbox
+
+ dosym "${DESTDIR}"/rocketchat-desktop /opt/bin/rocketchat-desktop
+ popd || die
+}