summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-11-20 09:47:49 +0100
committerUlrich Müller <ulm@gentoo.org>2023-11-20 09:48:37 +0100
commit3a72aeafb393926902a0b88e5511a7b8c21838a2 (patch)
tree645e000a6d3ef2b0f6fea4e34d09bf28ac938a60
parentmail-client/mutt: Stabilize 2.2.12 x86, #917611 (diff)
downloadgentoo-3a72aeaf.tar.gz
gentoo-3a72aeaf.tar.bz2
gentoo-3a72aeaf.zip
dev-vcs/cvs-fast-export: add 1.61
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--dev-vcs/cvs-fast-export/Manifest1
-rw-r--r--dev-vcs/cvs-fast-export/cvs-fast-export-1.61.ebuild38
-rw-r--r--dev-vcs/cvs-fast-export/files/cvs-fast-export-1.61-Makefile.patch20
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-vcs/cvs-fast-export/Manifest b/dev-vcs/cvs-fast-export/Manifest
index fe684f927845..433d5d1c7e28 100644
--- a/dev-vcs/cvs-fast-export/Manifest
+++ b/dev-vcs/cvs-fast-export/Manifest
@@ -1,2 +1,3 @@
DIST cvs-fast-export-1.57.tar.gz 503473 BLAKE2B 06d5b03d550be9604a04b4f03cd19d06abbe84efb6fbb424a3ae8c58f2964dff31e1718baf61adf70fe17c2beb6753cdd0fba9e0e1a5ba5e9d8ae7b87721a336 SHA512 bb129d58a66ca8aa9feb6dcdf6d83553ed1099d6023041c4fb8fa9b923461b6eb9e59ec304b3443f754d7710a2655fd2c104cbaa5ac604ee471de727b92fc091
DIST cvs-fast-export-1.59.tar.gz 514934 BLAKE2B 2e9f42eb948c917785f80596bf176cde8265555c8808fa8c7a297217dba6eb36f8de6cebc192ebb0bd513e3c288beefad01d04cd59a72176377851b00a25419a SHA512 3fd4455c61b9065b784396683bea6ca6fcae8509fabd72531d1dba7d733e1fedeb9307b99d02f03eb3d19e9b024f2c53e2a15062b46d96fe58ab90651ff94bc5
+DIST cvs-fast-export-1.61.tar.gz 525785 BLAKE2B 64089fe0f99e247505152ad20c618a721917fabcf28e29ede330e89d9ffc3b05e314e09deb85c9c23de95acfa6193a6dd67636374862d58df231e06fd8313f09 SHA512 505a305b3f383a9df0f519ec0bbf92d5fbd2759b5be39b3eced898a00bd06290f2905e6add49c992ff69fdf468f6c83e15e8810bdf12d08eec0289aa7930df4e
diff --git a/dev-vcs/cvs-fast-export/cvs-fast-export-1.61.ebuild b/dev-vcs/cvs-fast-export/cvs-fast-export-1.61.ebuild
new file mode 100644
index 000000000000..29ba3be62c3e
--- /dev/null
+++ b/dev-vcs/cvs-fast-export/cvs-fast-export-1.61.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="fast-export history from a CVS repository or RCS collection"
+HOMEPAGE="http://www.catb.org/~esr/cvs-fast-export/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT=test # upstream does not ship some tests in tarball
+
+BDEPEND="app-text/asciidoc"
+
+PATCHES=( "${FILESDIR}/${P}-Makefile.patch" )
+
+src_prepare() {
+ default
+ tc-export CC
+ export prefix="${EPREFIX}"/usr
+}
+
+src_compile() {
+ # '.adoc.html' rules can't be executed in parallel
+ # as they reuse the same 'docbook-xsl.css' file name.
+ emake -j1 html
+ # Allow full parallelism for the rest
+ emake
+}
+
+src_install() {
+ default
+ dodoc {NEWS,README,TODO,hacking,reporting-bugs}.adoc
+}
diff --git a/dev-vcs/cvs-fast-export/files/cvs-fast-export-1.61-Makefile.patch b/dev-vcs/cvs-fast-export/files/cvs-fast-export-1.61-Makefile.patch
new file mode 100644
index 000000000000..13ceeb3ccc3b
--- /dev/null
+++ b/dev-vcs/cvs-fast-export/files/cvs-fast-export-1.61-Makefile.patch
@@ -0,0 +1,20 @@
+--- cvs-fast-export-1.61/Makefile
++++ cvs-fast-export-1.61/Makefile
+@@ -36,7 +36,7 @@
+ GCC_WARNINGS2=-Wmissing-prototypes -Wmissing-declarations
+ GCC_WARNINGS3=-Wno-unused-function -Wno-unused-label -Wno-format-zero-length
+ GCC_WARNINGS=$(GCC_WARNINGS1) $(GCC_WARNINGS2) $(GCC_WARNINGS3)
+-CFLAGS += $(GCC_WARNINGS)
++#CFLAGS += $(GCC_WARNINGS)
+ CPPFLAGS += -I. -I$(srcdir)
+ #LIBS=-lrt
+ CPPFLAGS += -DVERSION=\"$(VERSION)\"
+@@ -83,7 +83,7 @@
+ # CFLAGS += -O2
+ # If your toolchain supports link time optimization this is a cheap speedup
+ # CFLAGS += -flto
+-CFLAGS += -g
++# CFLAGS += -g
+ # Test coverage flags
+ # CFLAGS += -ftest-coverage -fprofile-arcs
+ CFLAGS += $(EXTRA_CFLAGS)