summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-02-07 23:01:12 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-02-07 23:02:38 +0000
commit3a821c3499a6f99b780eec2d5dd81c785535600c (patch)
treeaf89874e202b1ec184d8f3f88e7bcdd33e563aa3
parenttoolchain-glibc.eclass: ignore USE=headers-only for native case, bug #677474 (diff)
downloadgentoo-3a821c34.tar.gz
gentoo-3a821c34.tar.bz2
gentoo-3a821c34.zip
sys-libs/glibc: ignore USE=headers-only for native case, bug #677474
Let's not allow users to "deinstall" native glibc. Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/677474 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--sys-libs/glibc/glibc-2.27-r6.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.28-r5.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.29.ebuild2
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild2
4 files changed, 5 insertions, 5 deletions
diff --git a/sys-libs/glibc/glibc-2.27-r6.ebuild b/sys-libs/glibc/glibc-2.27-r6.ebuild
index 7125f84f4dab..668e6795b243 100644
--- a/sys-libs/glibc/glibc-2.27-r6.ebuild
+++ b/sys-libs/glibc/glibc-2.27-r6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -459,7 +459,7 @@ setup_env() {
export ABI=${ABI:-${DEFAULT_ABI:-default}}
- if use headers-only ; then
+ if just_headers ; then
# Avoid mixing host's CC and target's CFLAGS_${ABI}:
# At this bootstrap stage we have only binutils for
# target but not compiler yet.
diff --git a/sys-libs/glibc/glibc-2.28-r5.ebuild b/sys-libs/glibc/glibc-2.28-r5.ebuild
index 0c69246759a4..827b432313ee 100644
--- a/sys-libs/glibc/glibc-2.28-r5.ebuild
+++ b/sys-libs/glibc/glibc-2.28-r5.ebuild
@@ -448,7 +448,7 @@ setup_env() {
export ABI=${ABI:-${DEFAULT_ABI:-default}}
- if use headers-only ; then
+ if just_headers ; then
# Avoid mixing host's CC and target's CFLAGS_${ABI}:
# At this bootstrap stage we have only binutils for
# target but not compiler yet.
diff --git a/sys-libs/glibc/glibc-2.29.ebuild b/sys-libs/glibc/glibc-2.29.ebuild
index 6ef8c8b6f230..3089cdbb5f1a 100644
--- a/sys-libs/glibc/glibc-2.29.ebuild
+++ b/sys-libs/glibc/glibc-2.29.ebuild
@@ -452,7 +452,7 @@ setup_env() {
export ABI=${ABI:-${DEFAULT_ABI:-default}}
- if use headers-only ; then
+ if just_headers ; then
# Avoid mixing host's CC and target's CFLAGS_${ABI}:
# At this bootstrap stage we have only binutils for
# target but not compiler yet.
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 6b5bd388a30e..1dcf217a492e 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -452,7 +452,7 @@ setup_env() {
export ABI=${ABI:-${DEFAULT_ABI:-default}}
- if use headers-only ; then
+ if just_headers ; then
# Avoid mixing host's CC and target's CFLAGS_${ABI}:
# At this bootstrap stage we have only binutils for
# target but not compiler yet.