summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-16 05:51:57 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-16 05:51:57 +0200
commit3a845204faf0ab336d427e3aae66dd710512e894 (patch)
tree460a45b2829fb77f4de58cb2a457791eee491c8f
parentdev-python/crispy-bootstrap4: Enable py3.12 (diff)
downloadgentoo-3a845204.tar.gz
gentoo-3a845204.tar.bz2
gentoo-3a845204.zip
dev-python/crispy-bootstrap3: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/crispy-bootstrap3/crispy-bootstrap3-2022.1.ebuild23
1 files changed, 15 insertions, 8 deletions
diff --git a/dev-python/crispy-bootstrap3/crispy-bootstrap3-2022.1.ebuild b/dev-python/crispy-bootstrap3/crispy-bootstrap3-2022.1.ebuild
index aa01b8d7ac26..fa1e6bbbaacd 100644
--- a/dev-python/crispy-bootstrap3/crispy-bootstrap3-2022.1.ebuild
+++ b/dev-python/crispy-bootstrap3/crispy-bootstrap3-2022.1.ebuild
@@ -4,24 +4,31 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
+
inherit distutils-r1
DESCRIPTION="Bootstrap3 template pack for django-crispy-forms"
HOMEPAGE="
+ https://github.com/django-crispy-forms/crispy-bootstrap3/
https://pypi.org/project/crispy-bootstrap3/
"
-SRC_URI="https://github.com/django-crispy-forms/${PN}/archive/refs/tags/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+SRC_URI="
+ https://github.com/django-crispy-forms/crispy-bootstrap3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RDEPEND="dev-python/django-crispy-forms[${PYTHON_USEDEP}]"
-BDEPEND="test? (
- dev-python/pytest-django[${PYTHON_USEDEP}]
-)"
+RDEPEND="
+ dev-python/django-crispy-forms[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest