summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2018-10-02 23:39:11 +0200
committerMichał Górny <mgorny@gentoo.org>2018-11-03 09:19:22 +0100
commit3a8f925a433e63fba963b59ceb5818c30c42310e (patch)
tree4fbd34a1228cab4755b7eb4ec83aa1b932efd9af
parentmedia-libs/opusfile: add LibreSSL support (diff)
downloadgentoo-3a8f925a.tar.gz
gentoo-3a8f925a.tar.bz2
gentoo-3a8f925a.zip
sci-libs/Rtree: bump to 0.8.3_p20180802
And bumped EAPI to 7 And added test suite Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Horea Christian <horea.christ@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10049 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sci-libs/Rtree/Manifest1
-rw-r--r--sci-libs/Rtree/Rtree-0.8.3_p20180802.ebuild27
-rw-r--r--sci-libs/Rtree/metadata.xml1
3 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/Rtree/Manifest b/sci-libs/Rtree/Manifest
index 335282a7baf2..db4f240ad24e 100644
--- a/sci-libs/Rtree/Manifest
+++ b/sci-libs/Rtree/Manifest
@@ -1 +1,2 @@
DIST Rtree-0.8.2.tar.gz 55813 BLAKE2B fd7391ef92c61a9d502d03376e1eef157dcfec77d3d46642d1b14bbe3a5021880641cbc741dd85e8b3b3d66a019db0a2eb638cfa76d109102459544969877eba SHA512 c0c1091c21e92022540a0aed09c00f3b2b6abb2869757e0cb7a68a120e3a289f275cea824a72172ea5b327696a67024894f5f01354f0cd5ec5b05d9b3ec130e0
+DIST Rtree-0.8.3_p20180802.tar.gz 48893 BLAKE2B bd0745e8e5051a772c2d50fe35712dc661737f32f6af382579dbbffc7467c21ef73bbeb794489da9891e50497b6f8775b1a670185453d54881e6dc8496fef539 SHA512 10c35a1d00369b3a30c486830d7cecdae6bd9bbc2ab9ea7f398227bc46b116783b1486cc75759eb27d7b25439400cbc39b55e6f58c686caec45bbc8436c6067c
diff --git a/sci-libs/Rtree/Rtree-0.8.3_p20180802.ebuild b/sci-libs/Rtree/Rtree-0.8.3_p20180802.ebuild
new file mode 100644
index 000000000000..2c31f17d56b2
--- /dev/null
+++ b/sci-libs/Rtree/Rtree-0.8.3_p20180802.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+EGIT_COMMIT_HASH="c6437a8ae182cb58aef1d0a4465bfc0c6f75b273"
+
+DESCRIPTION="R-Tree spatial index for Python GIS"
+HOMEPAGE="https://github.com/Toblerity/rtree"
+SRC_URI="https://github.com/Toblerity/rtree/archive/${EGIT_COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="sci-libs/libspatialindex"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/rtree-${EGIT_COMMIT_HASH}"
+
+python_test() {
+ pytest -vv || die
+}
diff --git a/sci-libs/Rtree/metadata.xml b/sci-libs/Rtree/metadata.xml
index 150a150f5ebe..0a6a504a6658 100644
--- a/sci-libs/Rtree/metadata.xml
+++ b/sci-libs/Rtree/metadata.xml
@@ -5,6 +5,7 @@
<email>slis@gentoo.org</email>
</maintainer>
<upstream>
+ <remote-id type="github">Toblerity/rtree</remote-id>
<remote-id type="pypi">Rtree</remote-id>
</upstream>
</pkgmetadata>