summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-05-05 15:46:02 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-05-05 15:46:16 +0200
commit3a94588919324503c7103b12b0417cb8741179aa (patch)
treeff0a0317667b9d7a0ee8e25db44d455c384e9e52
parentnet-misc/minidlna: Bump to 1.3.1 (diff)
downloadgentoo-3a94588919324503c7103b12b0417cb8741179aa.tar.gz
gentoo-3a94588919324503c7103b12b0417cb8741179aa.tar.bz2
gentoo-3a94588919324503c7103b12b0417cb8741179aa.zip
net-misc/curl: Fix compilation with USE=mbedtls,http2
Closes: https://bugs.gentoo.org/842780 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--net-misc/curl/curl-7.83.0.ebuild2
-rw-r--r--net-misc/curl/files/curl-7.83.0-http2.patch30
2 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/curl/curl-7.83.0.ebuild b/net-misc/curl/curl-7.83.0.ebuild
index 150319f8e7d6..041b6cd5a2e4 100644
--- a/net-misc/curl/curl-7.83.0.ebuild
+++ b/net-misc/curl/curl-7.83.0.ebuild
@@ -96,6 +96,8 @@ MULTILIB_CHOST_TOOLS=(
PATCHES=(
"${FILESDIR}"/${PN}-7.30.0-prefix.patch
"${FILESDIR}"/${PN}-respect-cflags-3.patch
+ # Bug 842780, fixed upstream, drop on next version bump
+ "${FILESDIR}"/${P}-http2.patch
)
src_prepare() {
diff --git a/net-misc/curl/files/curl-7.83.0-http2.patch b/net-misc/curl/files/curl-7.83.0-http2.patch
new file mode 100644
index 000000000000..ede69a177b98
--- /dev/null
+++ b/net-misc/curl/files/curl-7.83.0-http2.patch
@@ -0,0 +1,30 @@
+Bug: https://bugs.gentoo.org/842780, https://github.com/curl/curl/pull/8768
+https://github.com/curl/curl/commit/6eb7fb37d901ed1e4ce07cbd628ee11bf02db1f3
+
+From 6eb7fb37d901ed1e4ce07cbd628ee11bf02db1f3 Mon Sep 17 00:00:00 2001
+From: Daniel Stenberg <daniel@haxx.se>
+Date: Thu, 28 Apr 2022 17:11:50 +0200
+Subject: [PATCH] mbedtls: fix compile when h2-enabled
+
+Fixes #8766
+Reported-by: LigH-de on github
+Closes #8768
+---
+ lib/vtls/mbedtls.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/lib/vtls/mbedtls.c b/lib/vtls/mbedtls.c
+index 64f57c5d8321..5f9b87e6b75b 100644
+--- a/lib/vtls/mbedtls.c
++++ b/lib/vtls/mbedtls.c
+@@ -815,8 +815,8 @@ mbed_connect_step2(struct Curl_easy *data, struct connectdata *conn,
+ if(next_protocol) {
+ infof(data, VTLS_INFOF_ALPN_ACCEPTED_1STR, next_protocol);
+ #ifdef USE_HTTP2
+- if(!strncmp(next_protocol, ALPN_H2, ALPN_H2_LEN) &&
+- !next_protocol[ALPN_H2_LEN]) {
++ if(!strncmp(next_protocol, ALPN_H2, ALPN_H2_LENGTH) &&
++ !next_protocol[ALPN_H2_LENGTH]) {
+ conn->negnpn = CURL_HTTP_VERSION_2;
+ }
+ else