summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-05 20:41:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-05 20:43:18 +0200
commit3aa29e85ffce289b6dd191f6333f9d987808d0ef (patch)
treef8c496147b209b6c8c7c0c37e3318785917d4c8f
parentdev-python/yapsy: Enable py3.10 (diff)
downloadgentoo-3aa29e85ffce289b6dd191f6333f9d987808d0ef.tar.gz
gentoo-3aa29e85ffce289b6dd191f6333f9d987808d0ef.tar.bz2
gentoo-3aa29e85ffce289b6dd191f6333f9d987808d0ef.zip
dev-python/zc-lockfile: Enable py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/zc-lockfile/zc-lockfile-2.0.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/dev-python/zc-lockfile/zc-lockfile-2.0.ebuild b/dev-python/zc-lockfile/zc-lockfile-2.0.ebuild
index c7055d449fca..29784b2e318d 100644
--- a/dev-python/zc-lockfile/zc-lockfile-2.0.ebuild
+++ b/dev-python/zc-lockfile/zc-lockfile-2.0.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
@@ -12,17 +14,13 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="Basic inter-process locks"
HOMEPAGE="https://pypi.org/project/zc.lockfile/"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
LICENSE="ZPL"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ~ppc64 ~sparc x86"
-IUSE="test"
-RDEPEND=">=dev-python/setuptools-3.3[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}"/${MY_P}
+BDEPEND="test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )"
DOCS=( CHANGES.rst README.rst )