summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-30 03:40:04 +0100
committerSam James <sam@gentoo.org>2021-08-30 03:40:04 +0100
commit3acf4b018951f502f6e4044f3a959c0d7aae6831 (patch)
tree75bd58a80d28628a1cf325e3fbe1f1544caaf527
parentsys-process/procps: add stop-gap musl patch for now (diff)
downloadgentoo-3acf4b01.tar.gz
gentoo-3acf4b01.tar.bz2
gentoo-3acf4b01.zip
sys-process/procps: add workaround for cross compiles
Force the value of the configure test given upstream neglect the result and it builds fine with it. The test is too aggressive in cross-compile situations and gives unreliable results. See also: lists.gnu.org/archive/html/autoconf/2011-04/msg00019.html See: 0498c7f2801e67309d52220fe1492e37d9434df9 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-process/procps/procps-3.3.17-r1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/sys-process/procps/procps-3.3.17-r1.ebuild b/sys-process/procps/procps-3.3.17-r1.ebuild
index 2fa54d22f40c..7045b992c869 100644
--- a/sys-process/procps/procps-3.3.17-r1.ebuild
+++ b/sys-process/procps/procps-3.3.17-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic multilib-minimal usr-ldscript
+inherit flag-o-matic multilib-minimal toolchain-funcs usr-ldscript
DESCRIPTION="Standard informational utilities and process-handling tools"
HOMEPAGE="http://procps-ng.sourceforge.net/ https://gitlab.com/procps-ng/procps"
@@ -51,6 +51,16 @@ src_prepare() {
}
multilib_src_configure() {
+ if tc-is-cross-compiler ; then
+ # This isn't ideal but upstream don't provide a placement
+ # when malloc is missing anyway, leading to errors like:
+ # pslog.c:(.text.startup+0x108): undefined reference to `rpl_malloc'
+ # See https://sourceforge.net/p/psmisc/bugs/71/
+ # (and https://lists.gnu.org/archive/html/autoconf/2011-04/msg00019.html)
+ export ac_cv_func_malloc_0_nonnull=yes \
+ ac_cv_func_realloc_0_nonnull=yes
+ fi
+
# http://www.freelists.org/post/procps/PATCH-enable-transparent-large-file-support
append-lfs-flags #471102
local myeconfargs=(