summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-10-31 15:07:51 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-10-31 15:07:51 +0100
commit3ad02535560f95203cc489f2005b7c519272ed9a (patch)
tree0dad94099b93107c411f60b4361801cade8d18ec
parentsci-libs/openblas: update HOMEPAGE (diff)
downloadgentoo-3ad02535.tar.gz
gentoo-3ad02535.tar.bz2
gentoo-3ad02535.zip
app-arch/bzip3: bump to 1.2.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-arch/bzip3/Manifest1
-rw-r--r--app-arch/bzip3/bzip3-1.2.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/bzip3/Manifest b/app-arch/bzip3/Manifest
index d5c786793fc9..e8f2008c9ed6 100644
--- a/app-arch/bzip3/Manifest
+++ b/app-arch/bzip3/Manifest
@@ -1,3 +1,4 @@
DIST bzip3-1.1.5.tar.xz 265340 BLAKE2B 0226a97d564f1c9d9d1089b43ae79a9e43d0b77628298ef953c45505ad8d62caaf17bf6fa357857f123cf072b8ccd3003bfe138f25284baa5a5a5cdd8a555f71 SHA512 589c2e8e675a61014c7c4e82d0f2067201e3fb97bf7cfa6b7aa23690dc739824226089ac710509cc085b22eeb671ed5e23c6493967a433d3b284cb638af71be8
DIST bzip3-1.1.6.tar.xz 265708 BLAKE2B 9429dcb3e9deef8aafdf890215ba95669dbcb135d6d2896f18cc70b482bab321497d3a26f36be59700ad0da879578b7c906f20629c72642aa15fc3b1507a788a SHA512 19120d3a850495a5bcc43b124e4a8eddf41bac55119d0898bf1e7c5b744f4bcc84c41b9018615f577fe3bfdceab8dd2ab6f2722cb9fbf86bf1c0a2da9ca32916
DIST bzip3-1.1.8.tar.xz 269668 BLAKE2B fe85ba2ecca8e2433501c13e57856720da731b6c959340a68dd4654a516c12e034a90ff6cd6aed55dd2160c3860fdc3e60cddd47ffd00737a657a2e6c73704af SHA512 36141a48f0d5b35de4b06117ceca3c5d5cdc3df6be187856f1436751984b0154942e0eece531ee7b191cc0cd7056960de6a1ca3ec0fc2bcc7ff1d50444cd1e3e
+DIST bzip3-1.2.0.tar.xz 271664 BLAKE2B 5cdc257d86c88e808f506a4a3dd2a3eb365eda5ca064737386c46a65471934b32535383d844802574cc5274f306b82fef2e1adf12eb8c0059691c6e848d5eeda SHA512 02c653b9450ff41c7a164526d12fa601eed097c3badc6f7cce9b1f38db43c18b315a9f0cc49b47e9d87548b42f1a627b11eb4f956a60176465089f94f985562a
diff --git a/app-arch/bzip3/bzip3-1.2.0.ebuild b/app-arch/bzip3/bzip3-1.2.0.ebuild
new file mode 100644
index 000000000000..0d9329da48ca
--- /dev/null
+++ b/app-arch/bzip3/bzip3-1.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A better and stronger spiritual successor to BZip2"
+HOMEPAGE="https://github.com/kspalaiologos/bzip3"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kspalaiologos/${PN}.git"
+else
+ SRC_URI="https://github.com/kspalaiologos/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+
+src_configure() {
+ # ./configure script will default to Clang if it is found on the system,
+ # force the use of CC selected by the user with CC=$(tc-getCC)
+ econf CC=$(tc-getCC)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}