summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-05-18 14:27:38 +0200
committerLars Wendler <polynomial-c@gentoo.org>2022-05-18 14:27:49 +0200
commit3af5208d3dcb070081dca7a01ae415d52b5c04b1 (patch)
treecc2ea64ace10476e417ddd3bc3fa0fc6945aa627
parentnet-misc/kea: Removed old (diff)
downloadgentoo-3af5208d3dcb070081dca7a01ae415d52b5c04b1.tar.gz
gentoo-3af5208d3dcb070081dca7a01ae415d52b5c04b1.tar.bz2
gentoo-3af5208d3dcb070081dca7a01ae415d52b5c04b1.zip
net-misc/kea: Synced live ebuild
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--net-misc/kea/kea-9999.ebuild41
1 files changed, 33 insertions, 8 deletions
diff --git a/net-misc/kea/kea-9999.ebuild b/net-misc/kea/kea-9999.ebuild
index 9f241b088227..aca4fe99e606 100644
--- a/net-misc/kea/kea-9999.ebuild
+++ b/net-misc/kea/kea-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
MY_PV="${PV//_p/-P}"
MY_PV="${MY_PV/_/-}"
@@ -10,7 +10,9 @@ MY_P="${PN}-${MY_PV}"
DESCRIPTION="High-performance production grade DHCPv4 & DHCPv6 server"
HOMEPAGE="https://www.isc.org/kea/"
-inherit autotools systemd tmpfiles
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools fcaps python-single-r1 systemd tmpfiles
if [[ ${PV} = 9999* ]] ; then
inherit git-r3
@@ -18,34 +20,53 @@ if [[ ${PV} = 9999* ]] ; then
else
SRC_URI="ftp://ftp.isc.org/isc/kea/${MY_P}.tar.gz
ftp://ftp.isc.org/isc/kea/${MY_PV}/${MY_P}.tar.gz"
- [[ "${PV}" == *_beta* ]] || [[ "${PV}" == *_rc* ]] || \
- KEYWORDS="~amd64 ~arm64 ~x86"
+ # Odd minor version = development release
+ if [[ $(( $(ver_cut 2) % 2 )) -ne 1 ]] ; then
+ [[ "${PV}" == *_beta* ]] || [[ "${PV}" == *_rc* ]] || \
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ fi
fi
LICENSE="ISC BSD SSLeay GPL-2" # GPL-2 only for init script
SLOT="0"
-IUSE="mysql +openssl postgres +samples"
+IUSE="mysql +openssl postgres +samples shell test"
+RESTRICT="!test? ( test )"
-DEPEND="
+COMMON_DEPEND="
dev-libs/boost:=
dev-libs/log4cplus
mysql? ( dev-db/mysql-connector-c )
!openssl? ( dev-libs/botan:2= )
openssl? ( dev-libs/openssl:0= )
postgres? ( dev-db/postgresql:* )
+ shell? ( ${PYTHON_DEPS} )
"
-RDEPEND="${DEPEND}
+DEPEND="${COMMON_DEPEND}
+ test? ( dev-cpp/gtest )
+"
+RDEPEND="${COMMON_DEPEND}
acct-group/dhcp
acct-user/dhcp"
BDEPEND="virtual/pkgconfig"
+REQUIRED_USE="shell? ( ${PYTHON_REQUIRED_USE} )"
+
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.2-boost-1.77.0.patch
+ "${FILESDIR}"/${PN}-1.9.10-gtest.patch
+)
+
+pkg_setup() {
+ use shell && python-single-r1_pkg_setup
+}
+
src_prepare() {
default
# Brand the version with Gentoo
sed -i \
- -e "s/AC_INIT(kea,${PV}.*, kea-dev@lists.isc.org)/AC_INIT(kea,${PVR}-gentoo, kea-dev@lists.isc.org)/g" \
+ -e "s/AC_INIT(kea,${PV}.*, kea-dev@lists.isc.org)/AC_INIT([kea], [${PVR}-gentoo], [kea-dev@lists.isc.org])/g" \
configure.ac || die
sed -i \
@@ -59,10 +80,13 @@ src_configure() {
local myeconfargs=(
--disable-install-configurations
--disable-static
+ --enable-generate-messages
--enable-perfdhcp
--localstatedir="${EPREFIX}/var"
--runstatedir="${EPREFIX}/run"
--without-werror
+ $(use_enable test gtest)
+ $(use_enable shell)
$(use_with mysql)
$(use_with openssl)
$(use_with postgres pgsql)
@@ -99,4 +123,5 @@ src_install() {
pkg_postinst() {
tmpfiles_process ${PN}.conf
+ fcaps cap_net_bind_service,cap_net_raw=+ep /usr/sbin/kea-dhcp{4,6}
}