summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2023-12-01 09:51:48 +0100
committerGuilherme Amadio <amadio@gentoo.org>2023-12-05 13:16:25 +0100
commit3afed6351c5865fa3c1f3afed0da6e5a540d9aad (patch)
tree3aeeeb4dc022b27482f8835d5f76e30a6fc16453
parentsci-physics/root: drop USE flags for C++ standard (diff)
downloadgentoo-3afed6351c5865fa3c1f3afed0da6e5a540d9aad.tar.gz
gentoo-3afed6351c5865fa3c1f3afed0da6e5a540d9aad.tar.bz2
gentoo-3afed6351c5865fa3c1f3afed0da6e5a540d9aad.zip
sci-physics/geant: drop USE flags for C++ standard
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
-rw-r--r--sci-physics/geant/geant-4.11.0.4-r1.ebuild (renamed from sci-physics/geant/geant-4.11.0.4.ebuild)4
-rw-r--r--sci-physics/geant/geant-4.11.1.2-r1.ebuild (renamed from sci-physics/geant/geant-4.11.1.2.ebuild)4
-rw-r--r--sci-physics/geant/geant-4.11.1.3-r1.ebuild (renamed from sci-physics/geant/geant-4.11.1.3.ebuild)4
-rw-r--r--sci-physics/geant/metadata.xml2
4 files changed, 3 insertions, 11 deletions
diff --git a/sci-physics/geant/geant-4.11.0.4.ebuild b/sci-physics/geant/geant-4.11.0.4-r1.ebuild
index 46177ea9e071..78172acdf4ed 100644
--- a/sci-physics/geant/geant-4.11.0.4.ebuild
+++ b/sci-physics/geant/geant-4.11.0.4-r1.ebuild
@@ -28,11 +28,10 @@ SRC_URI="https://geant4-data.web.cern.ch/geant4-data/releases/${MY_P}.tar.gz"
LICENSE="geant4"
SLOT="4"
KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="+c++17 c++20 +data debug doc examples freetype gdml geant3 hdf5 inventor motif opengl
+IUSE="+data debug doc examples freetype gdml geant3 hdf5 inventor motif opengl
python qt5 raytracerx static-libs tbb threads trajectories vtk"
REQUIRED_USE="
- ^^ ( c++17 c++20 )
inventor? ( opengl )
motif? ( opengl )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -82,7 +81,6 @@ PATCHES=(
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_DATADIR="${EPREFIX}/usr/share/geant4"
- -DCMAKE_CXX_STANDARD=$( (usev c++17 || usev c++20) | cut -c4-)
-DGEANT4_BUILD_BUILTIN_BACKTRACE=$(usex debug)
-DGEANT4_BUILD_MULTITHREADED=$(usex threads)
-DGEANT4_BUILD_STORE_TRAJECTORY=$(usex trajectories)
diff --git a/sci-physics/geant/geant-4.11.1.2.ebuild b/sci-physics/geant/geant-4.11.1.2-r1.ebuild
index f3b3080d4a6c..ba5da9da5760 100644
--- a/sci-physics/geant/geant-4.11.1.2.ebuild
+++ b/sci-physics/geant/geant-4.11.1.2-r1.ebuild
@@ -26,11 +26,10 @@ SRC_URI="https://geant4-data.web.cern.ch/geant4-data/releases/${MY_P}.tar.gz"
LICENSE="geant4"
SLOT="4"
KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="+c++17 c++20 +data debug doc examples freetype gdml geant3 hdf5 inventor motif opengl
+IUSE="+data debug doc examples freetype gdml geant3 hdf5 inventor motif opengl
qt5 raytracerx static-libs tbb threads trajectories vtk"
REQUIRED_USE="
- ^^ ( c++17 c++20 )
inventor? ( opengl )
motif? ( opengl )
qt5? ( opengl )
@@ -73,7 +72,6 @@ PATCHES=(
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_DATADIR="${EPREFIX}/usr/share/geant4"
- -DCMAKE_CXX_STANDARD=$( (usev c++17 || usev c++20) | cut -c4-)
-DGEANT4_BUILD_BUILTIN_BACKTRACE=$(usex debug)
-DGEANT4_BUILD_MULTITHREADED=$(usex threads)
-DGEANT4_BUILD_STORE_TRAJECTORY=$(usex trajectories)
diff --git a/sci-physics/geant/geant-4.11.1.3.ebuild b/sci-physics/geant/geant-4.11.1.3-r1.ebuild
index f27e52f2f965..8ad0f4053b14 100644
--- a/sci-physics/geant/geant-4.11.1.3.ebuild
+++ b/sci-physics/geant/geant-4.11.1.3-r1.ebuild
@@ -26,11 +26,10 @@ SRC_URI="https://geant4-data.web.cern.ch/geant4-data/releases/${MY_P}.tar.gz"
LICENSE="geant4"
SLOT="4"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="+c++17 c++20 +data debug doc examples freetype gdml geant3 hdf5 inventor motif opengl
+IUSE="+data debug doc examples freetype gdml geant3 hdf5 inventor motif opengl
qt5 raytracerx static-libs tbb threads trajectories vtk"
REQUIRED_USE="
- ^^ ( c++17 c++20 )
inventor? ( opengl )
motif? ( opengl )
qt5? ( opengl )
@@ -73,7 +72,6 @@ PATCHES=(
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_DATADIR="${EPREFIX}/usr/share/geant4"
- -DCMAKE_CXX_STANDARD=$( (usev c++17 || usev c++20) | cut -c4-)
-DGEANT4_BUILD_BUILTIN_BACKTRACE=$(usex debug)
-DGEANT4_BUILD_MULTITHREADED=$(usex threads)
-DGEANT4_BUILD_STORE_TRAJECTORY=$(usex trajectories)
diff --git a/sci-physics/geant/metadata.xml b/sci-physics/geant/metadata.xml
index e30535f60f9a..c3ee4dbc5921 100644
--- a/sci-physics/geant/metadata.xml
+++ b/sci-physics/geant/metadata.xml
@@ -15,8 +15,6 @@
features and detectors.
</longdescription>
<use>
- <flag name="c++17">Build using the C++17 standard</flag>
- <flag name="c++20">Build using the C++20 standard</flag>
<flag name="data">Add a lot of standard physics data files for geant4</flag>
<flag name="freetype">Add support for <pkg>media-libs/freetype</pkg></flag>
<flag name="gdml">Enable geometry markup language for xml</flag>