summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-04-07 12:46:03 -0400
committerYixun Lan <dlan@gentoo.org>2024-04-08 12:52:10 +0000
commit3b1aee3c2e0c51f7969ac2e2a4c9c96ba886a24b (patch)
treea6479e15534a4e3dbcb98c71862ae02ba71ea1b2
parentdev-build/cmake: add 3.29.1 (diff)
downloadgentoo-3b1aee3c2e0c51f7969ac2e2a4c9c96ba886a24b.tar.gz
gentoo-3b1aee3c2e0c51f7969ac2e2a4c9c96ba886a24b.tar.bz2
gentoo-3b1aee3c2e0c51f7969ac2e2a4c9c96ba886a24b.zip
gui-libs/hyprcursor: add 0.1.6
Signed-off-by: Julien Roy <julien@jroy.ca> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--gui-libs/hyprcursor/Manifest1
-rw-r--r--gui-libs/hyprcursor/hyprcursor-0.1.6.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/gui-libs/hyprcursor/Manifest b/gui-libs/hyprcursor/Manifest
index 5849c2c823b9..0b7e0b5fa4ec 100644
--- a/gui-libs/hyprcursor/Manifest
+++ b/gui-libs/hyprcursor/Manifest
@@ -1,2 +1,3 @@
DIST hyprcursor-0.1.4.gh.tar.gz 20072 BLAKE2B 9f4aafc673185ca522f16325529de30fb24cc962779358bc06e21fc148adae64156731d4d3e4a1f7bb2d72d4592cb238b8fefe33c473e86a1678cc5ec8677725 SHA512 6af0a81c39b73c804f5587be7a626db125a99318089c39769a26a4c2ebf0322a82c4ef690f0fda3b60301972bfd1c3a489209fa8157e6a43dec52fa2a6ccb9c9
DIST hyprcursor-0.1.5.gh.tar.gz 20096 BLAKE2B 31595ca4ffb0e9683d2584dc1e58483435bd19180a4326d741b4093d780b79878e9202153744b54786ed82991469ddd277112a79b3a3a95179195519cdfe9ff9 SHA512 3092b6773a34fa1cab10f83fa48274d79a50cd373dfe8a89d0170a78767a66b5e0cbe57cd1b86bc4bb85371c23ac7425f59e61fb50723a895fef4e7f6039fdfc
+DIST hyprcursor-0.1.6.gh.tar.gz 25562 BLAKE2B 7322884f01f69224b6dd9482dd2fd98df1d15ab8c9c8bb3ccae2699d35e0a28d6a7f5c5e1e14cc09516481f8300c32e396351175961cce8bcbf9eae488ce9cf5 SHA512 7e83b79a167016d658c41165eda945a35752f4b2e00cb401daf5c7778f8d90442a5a6ed40ce79a000f78d75a45383433ce131db34c25e14d3ae5942713ccb961
diff --git a/gui-libs/hyprcursor/hyprcursor-0.1.6.ebuild b/gui-libs/hyprcursor/hyprcursor-0.1.6.ebuild
new file mode 100644
index 000000000000..25a590acd7d2
--- /dev/null
+++ b/gui-libs/hyprcursor/hyprcursor-0.1.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="The hyprland cursor format, library and utilities"
+HOMEPAGE="https://github.com/hyprwm/hyprcursor"
+SRC_URI="https://github.com/hyprwm/hyprcursor/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+# Disable tests since as per upstream, tests require a theme to be installed
+# See also https://github.com/hyprwm/hyprcursor/commit/94361fd8a75178b92c4bb24dcd8c7fac8423acf3
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-libs/hyprlang-0.4.2
+ dev-libs/libzip
+ gnome-base/librsvg:2
+ x11-libs/cairo
+"