summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-09-18 19:08:33 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-09-19 22:37:31 +0200
commit3b2b4a41daf956cb87f44ff7dbe75ed48b679990 (patch)
treea68b0783301a717eece104bbedb243cdb1c42f7e
parentx11-plugins/wmtop: EAPI8 bump (diff)
downloadgentoo-3b2b4a41daf956cb87f44ff7dbe75ed48b679990.tar.gz
gentoo-3b2b4a41daf956cb87f44ff7dbe75ed48b679990.tar.bz2
gentoo-3b2b4a41daf956cb87f44ff7dbe75ed48b679990.zip
x11-plugins/wmtz: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--x11-plugins/wmtz/wmtz-0.7_p20150816-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-plugins/wmtz/wmtz-0.7_p20150816-r1.ebuild b/x11-plugins/wmtz/wmtz-0.7_p20150816-r1.ebuild
new file mode 100644
index 000000000000..e1f37b53111b
--- /dev/null
+++ b/x11-plugins/wmtz/wmtz-0.7_p20150816-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Dockapp that shows the time in multiple timezones"
+HOMEPAGE="https://www.dockapps.net/wmtz"
+# https://www.dockapps.net/download/${P}.tar.gz
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+S="${WORKDIR}/${P}/${PN}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ #Honour Gentoo LDFLAGS, see bug #337890.
+ sed -e "s/\$(FLAGS) -o wmtz/\$(LDFLAGS) -o wmtz/" -i Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" FLAGS="${CFLAGS}" \
+ LIBDIR="-L/usr/$(get_libdir)"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ insinto /etc
+ doins wmtzrc
+ dodoc ../{BUGS,CHANGES,README}
+}