summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-10-24 12:43:22 -0500
committerBen Kohler <bkohler@gentoo.org>2022-10-25 07:50:24 -0500
commit3b2c8f03c4ac603b87994c88e565741902e2cf6a (patch)
tree947bb57dfb10beee66270ea9cc0a4b38a2565bb8
parentdev-python/kgb: Stabilize 7.1.1 amd64, #878217 (diff)
downloadgentoo-3b2c8f03c4ac603b87994c88e565741902e2cf6a.tar.gz
gentoo-3b2c8f03c4ac603b87994c88e565741902e2cf6a.tar.bz2
gentoo-3b2c8f03c4ac603b87994c88e565741902e2cf6a.zip
dev-libs/libcpuid: add 0.6.1
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--dev-libs/libcpuid/Manifest1
-rw-r--r--dev-libs/libcpuid/libcpuid-0.6.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/libcpuid/Manifest b/dev-libs/libcpuid/Manifest
index 23f1f5e328da..a897f5fb7bf9 100644
--- a/dev-libs/libcpuid/Manifest
+++ b/dev-libs/libcpuid/Manifest
@@ -1,2 +1,3 @@
DIST libcpuid-0.5.1.tar.gz 166522 BLAKE2B 3471c11bbe4b0eaac7b00ac20a27556a95991f1b678269ae6f142a0fe2db066ebb756722ae2e76f95158742c93e29a35da6e735226d32b746034acae3ec2a5b7 SHA512 d725bc82e5aa2db69cea7b3590afbe11d6028cf4802fde8d498b4f1cc6d823e73d71b89a453d81bf996d97b36a71f6c00d0f6e8292b72f2be8a64b5d59c01861
DIST libcpuid-0.6.0.tar.gz 240709 BLAKE2B 6be56956d17aab774282b3e2be83b02f0180153af9cea665dbf8a8a216b35fd8c030b053184d09ac3946d163943281ecb906134290516d8063380749944339e8 SHA512 9f80f0d45f408d35d9ee657d8f53c99bb14e37d26a8a7b6a914546f0446f83a3d75eb06d261c7708a810ba10ce6fadaef54ba7c94cbf22cd113a9f2210c1a708
+DIST libcpuid-0.6.1.tar.gz 255938 BLAKE2B 80239930d7259b76289f6130c720d1700ae3a10be2a29b118cc8db38fb72f821b1d1a01afef06e00b2a3678b91b660ccd101eaf50af442a80166a508eb435294 SHA512 ccdb486a848f01a4f977c6f6b7ca59a2e65a7e04665e1a04bc3a57f1e8a68617f8bfbb2a71a1c93465bbaa7cc060fd7d120bbcb1a17fa004981e1074a4788818
diff --git a/dev-libs/libcpuid/libcpuid-0.6.1.ebuild b/dev-libs/libcpuid/libcpuid-0.6.1.ebuild
new file mode 100644
index 000000000000..c3576366dccf
--- /dev/null
+++ b/dev-libs/libcpuid/libcpuid-0.6.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=(python3_{9..11})
+
+inherit autotools python-any-r1
+
+DESCRIPTION="A small C library for x86 (and x86_64) CPU detection and feature extraction"
+HOMEPAGE="http://libcpuid.sourceforge.net/"
+SRC_URI="https://github.com/anrieff/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0/16"
+KEYWORDS="~amd64"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf "$(use_enable static-libs static)"
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}