summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-30 07:32:36 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-30 08:08:15 +0100
commit3b6ac50cc80de755a481b475e10a54305c1056a6 (patch)
tree34deeb0d1b7b69854cab555fc6165d62a7e2d5b6
parentdev-python/tox: Bump to 4.1.1 (diff)
downloadgentoo-3b6ac50c.tar.gz
gentoo-3b6ac50c.tar.bz2
gentoo-3b6ac50c.zip
dev-python/nbsphinx: Bump to 0.8.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nbsphinx/Manifest1
-rw-r--r--dev-python/nbsphinx/nbsphinx-0.8.11.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/nbsphinx/Manifest b/dev-python/nbsphinx/Manifest
index 7c66dff4c457..ae0cc953f668 100644
--- a/dev-python/nbsphinx/Manifest
+++ b/dev-python/nbsphinx/Manifest
@@ -1 +1,2 @@
DIST nbsphinx-0.8.10.tar.gz 177352 BLAKE2B e9fce12b59afe4b364be36ecfe4abc98e9444feafd52fa647ca2832622d875f78389928961d2c53235f466c55e9e1aee8ecf9db6751dfe7d0db8d40502876459 SHA512 a010ceff90d59d3cbff7953c1c807b9ff23661e1fb2255d5af151f6a1b4a2441f7a836a4fbea5ed11eda42ca8a0eae091ffe7d87c09940480d5f4e3311bb177b
+DIST nbsphinx-0.8.11.tar.gz 177598 BLAKE2B 5a8db76cdc39b19ec883f1ee58331248cc952786ffbe1a5ac75261a8258a9f36370366bf7654c6eecfdae17b324dab6ff2981c791dcdfb15cabeb0eea3b3f9ba SHA512 fb3e6d8074b639adc810ec0970e22d7f50bcadc072cacb0601bd9da3eece16c8af052360ecdd5c66b61ce4146deae10e44c3acd431073bd6086cc524b6861002
diff --git a/dev-python/nbsphinx/nbsphinx-0.8.11.ebuild b/dev-python/nbsphinx/nbsphinx-0.8.11.ebuild
new file mode 100644
index 000000000000..c39328378976
--- /dev/null
+++ b/dev-python/nbsphinx/nbsphinx-0.8.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Notebook Tools for Sphinx"
+HOMEPAGE="
+ https://github.com/spatialaudio/nbsphinx/
+ https://pypi.org/project/nbsphinx/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.8[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5[${PYTHON_USEDEP}]
+"