summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-11-11 22:32:28 -0500
committerLars Wendler <polynomial-c@gentoo.org>2018-11-16 08:46:31 +0100
commit3b72a744702238e2aedb7cad6f57ee95096a1fed (patch)
tree7f76d2aca750e366c8b35a10e5251f18dc9bf065
parentdev-ruby/rdoc: cleanup (diff)
downloadgentoo-3b72a744.tar.gz
gentoo-3b72a744.tar.bz2
gentoo-3b72a744.zip
net-fs/samba: Fix compatibility issues with the timespec struct
Closes: https://bugs.gentoo.org/666548 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/10396 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--net-fs/samba/files/samba-4.9.2-timespec.patch21
-rw-r--r--net-fs/samba/samba-4.9.2-r1.ebuild (renamed from net-fs/samba/samba-4.9.2.ebuild)1
2 files changed, 22 insertions, 0 deletions
diff --git a/net-fs/samba/files/samba-4.9.2-timespec.patch b/net-fs/samba/files/samba-4.9.2-timespec.patch
new file mode 100644
index 000000000000..c82f4af4e7ea
--- /dev/null
+++ b/net-fs/samba/files/samba-4.9.2-timespec.patch
@@ -0,0 +1,21 @@
+From 11e8c14b78e2423041f3846882f74cd6490a3e44 Mon Sep 17 00:00:00 2001
+From: Joan Karadimov <joan@profuzdigital.com>
+Date: Thu, 18 Oct 2018 18:16:17 +0300
+Subject: [PATCH] Fix compatibility issues with the timespec struct
+
+---
+ source3/include/libsmbclient.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/source3/include/libsmbclient.h b/source3/include/libsmbclient.h
+index 5e4a1715402..6487ea7a8aa 100644
+--- a/source3/include/libsmbclient.h
++++ b/source3/include/libsmbclient.h
+@@ -78,6 +78,7 @@ extern "C" {
+ #include <sys/statvfs.h>
+ #include <stdint.h>
+ #include <fcntl.h>
++#include <time.h>
+ #include <utime.h>
+
+ #define SMBC_BASE_FD 10000 /* smallest file descriptor returned */
diff --git a/net-fs/samba/samba-4.9.2.ebuild b/net-fs/samba/samba-4.9.2-r1.ebuild
index 474ff007b0b6..9552e026df24 100644
--- a/net-fs/samba/samba-4.9.2.ebuild
+++ b/net-fs/samba/samba-4.9.2-r1.ebuild
@@ -132,6 +132,7 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}/${PN}-4.4.0-pam.patch"
"${FILESDIR}/${PN}-4.5.1-compile_et_fix.patch"
+ "${FILESDIR}/${PN}-4.9.2-timespec.patch"
)
#CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"