summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-14 21:59:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-14 23:35:16 +0200
commit3b78756c595858154584153998ed0e2c854cffac (patch)
treedd56cdf0f0a39c8bc4211d039ec8c158876ffbbe
parentdev-python/google-auth: Bump to 2.1.0 (diff)
downloadgentoo-3b78756c.tar.gz
gentoo-3b78756c.tar.bz2
gentoo-3b78756c.zip
dev-python/cmd2: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cmd2/Manifest1
-rw-r--r--dev-python/cmd2/cmd2-2.2.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/cmd2/Manifest b/dev-python/cmd2/Manifest
index 5e1f0860e1f6..95541b963f2e 100644
--- a/dev-python/cmd2/Manifest
+++ b/dev-python/cmd2/Manifest
@@ -1 +1,2 @@
DIST cmd2-2.1.2.tar.gz 660849 BLAKE2B a8c8db8036badc020b34e6d4cc62a6828a6f3788562d550826369d2ce6ddc41fdd29ab95bd56d35115a1e8c2cfdb6df97e3b25c3f414798aed9a597243b37967 SHA512 3f2edb336ec662e3b2e22abc947ffb669786142d29f0723b0d5bbf898ecff12096a91e08c4890dde79915b413c0f9a70945f1b5795ae12991e85d7ee79331d31
+DIST cmd2-2.2.0.tar.gz 667076 BLAKE2B babdf4034ea45cebce0a9b037e0bef0127c924e358c68ab6a2b95e73ed3be4577dead28d2eebce721432fefe7d2590a3e904ba84dc17bf7c06e3f777dc7b0db0 SHA512 20c204c5e5996e18face62066a179a9833c468724a947042a3b5aaf49940cad0c773ea22e7f40b8c721f7362dcefa9eb72072710072e608c4adab615332bdc22
diff --git a/dev-python/cmd2/cmd2-2.2.0.ebuild b/dev-python/cmd2/cmd2-2.2.0.ebuild
new file mode 100644
index 000000000000..c892c9da8cf5
--- /dev/null
+++ b/dev-python/cmd2/cmd2-2.2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Extra features for standard library's cmd module"
+HOMEPAGE="https://github.com/python-cmd2/cmd2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.7[${PYTHON_USEDEP}]
+ >=dev-python/pyperclip-1.6[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+# pyperclip uses clipboard backends in the following preference order:
+# pygtk, xclip, xsel, klipper, qtpy, pyqt5, pyqt4.
+# klipper is known to be broken in Xvfb, and therefore causes test
+# failures. to avoid them, we must ensure that one of the backends
+# preferred to it is available (i.e. xclip or xsel) + which(1).
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ sys-apps/which
+ || (
+ x11-misc/xclip
+ x11-misc/xsel
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e '/--cov/d' setup.cfg || die
+}
+
+src_test() {
+ # tests rely on very specific text wrapping...
+ local -x COLUMNS=80
+ virtx distutils-r1_src_test
+}