summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2023-03-18 11:15:12 +0900
committerAkinori Hattori <hattya@gentoo.org>2023-03-18 11:15:12 +0900
commit3b7cbc03c5fa67926b0597e950cc7c66d03f8a37 (patch)
treebff9c9b2f7c2bdc3e655468c0fb9233ae3fac763
parentsys-devel/gcc: add 11.3.1_p20230317 (diff)
downloadgentoo-3b7cbc03.tar.gz
gentoo-3b7cbc03.tar.bz2
gentoo-3b7cbc03.zip
www-servers/h2o: fix build with >=dev-lang/ruby-3.0
Closes: https://bugs.gentoo.org/899572 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
-rw-r--r--www-servers/h2o/files/h2o-2.2-ruby30.patch63
-rw-r--r--www-servers/h2o/h2o-2.2.6-r1.ebuild7
2 files changed, 68 insertions, 2 deletions
diff --git a/www-servers/h2o/files/h2o-2.2-ruby30.patch b/www-servers/h2o/files/h2o-2.2-ruby30.patch
new file mode 100644
index 000000000000..47692d68bba5
--- /dev/null
+++ b/www-servers/h2o/files/h2o-2.2-ruby30.patch
@@ -0,0 +1,63 @@
+--- a/deps/mruby/Rakefile
++++ b/deps/mruby/Rakefile
+@@ -37,15 +37,15 @@
+ task :default => :all
+
+ bin_path = ENV['INSTALL_DIR'] || "#{MRUBY_ROOT}/bin"
+-FileUtils.mkdir_p bin_path, { :verbose => $verbose }
++FileUtils.mkdir_p bin_path, :verbose => $verbose
+
+ depfiles = MRuby.targets['host'].bins.map do |bin|
+ install_path = MRuby.targets['host'].exefile("#{bin_path}/#{bin}")
+ source_path = MRuby.targets['host'].exefile("#{MRuby.targets['host'].build_dir}/bin/#{bin}")
+
+ file install_path => source_path do |t|
+- FileUtils.rm_f t.name, { :verbose => $verbose }
+- FileUtils.cp t.prerequisites.first, t.name, { :verbose => $verbose }
++ FileUtils.rm_f t.name, :verbose => $verbose
++ FileUtils.cp t.prerequisites.first, t.name, :verbose => $verbose
+ end
+
+ install_path
+@@ -78,8 +78,8 @@
+ install_path = MRuby.targets['host'].exefile("#{bin_path}/#{bin}")
+
+ file install_path => exec do |t|
+- FileUtils.rm_f t.name, { :verbose => $verbose }
+- FileUtils.cp t.prerequisites.first, t.name, { :verbose => $verbose }
++ FileUtils.rm_f t.name, :verbose => $verbose
++ FileUtils.cp t.prerequisites.first, t.name, :verbose => $verbose
+ end
+ depfiles += [ install_path ]
+ elsif target == MRuby.targets['host-debug']
+@@ -87,8 +87,8 @@
+ install_path = MRuby.targets['host-debug'].exefile("#{bin_path}/#{bin}")
+
+ file install_path => exec do |t|
+- FileUtils.rm_f t.name, { :verbose => $verbose }
+- FileUtils.cp t.prerequisites.first, t.name, { :verbose => $verbose }
++ FileUtils.rm_f t.name, :verbose => $verbose
++ FileUtils.cp t.prerequisites.first, t.name, :verbose => $verbose
+ end
+ depfiles += [ install_path ]
+ end
+@@ -127,16 +127,16 @@
+ desc "clean all built and in-repo installed artifacts"
+ task :clean do
+ MRuby.each_target do |t|
+- FileUtils.rm_rf t.build_dir, { :verbose => $verbose }
++ FileUtils.rm_rf t.build_dir, :verbose => $verbose
+ end
+- FileUtils.rm_f depfiles, { :verbose => $verbose }
++ FileUtils.rm_f depfiles, :verbose => $verbose
+ puts "Cleaned up target build folder"
+ end
+
+ desc "clean everything!"
+ task :deep_clean => ["clean"] do
+ MRuby.each_target do |t|
+- FileUtils.rm_rf t.gem_clone_dir, { :verbose => $verbose }
++ FileUtils.rm_rf t.gem_clone_dir, :verbose => $verbose
+ end
+ puts "Cleaned up mrbgems build folder"
+ end
diff --git a/www-servers/h2o/h2o-2.2.6-r1.ebuild b/www-servers/h2o/h2o-2.2.6-r1.ebuild
index 33ece8ab07b7..2871e3f8b93b 100644
--- a/www-servers/h2o/h2o-2.2.6-r1.ebuild
+++ b/www-servers/h2o/h2o-2.2.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -38,7 +38,10 @@ BDEPEND="libh2o? ( virtual/pkgconfig )
virtual/pkgconfig
)"
-PATCHES=( "${FILESDIR}"/${PN}-2.2-mruby.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2-mruby.patch
+ "${FILESDIR}"/${PN}-2.2-ruby30.patch
+)
src_prepare() {
cmake_src_prepare