summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-25 23:36:18 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-25 23:58:47 +0200
commit3b8c487fd40bbd4b6639aa14f87d8ac335bf4a5c (patch)
tree8d57ce50083a3bd27bb6a3dbdd57182a326b149c
parentdev-python/arpeggio: Add python@ as co-maint. (diff)
downloadgentoo-3b8c487f.tar.gz
gentoo-3b8c487f.tar.bz2
gentoo-3b8c487f.zip
dev-python/astroid: Bump to 2.5.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/astroid/Manifest1
-rw-r--r--dev-python/astroid/astroid-2.5.6.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index 2a1cb7ec193d..17fab663f01c 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -2,4 +2,5 @@ DIST astroid-2.5.1.tar.gz 312511 BLAKE2B 85d85c045579f6bf42a4640da95836e760d1d89
DIST astroid-2.5.2.tar.gz 312789 BLAKE2B 53b286a8772fea1df149aff19f56c0d86154e616a04f4e3e459e029bd4ae54e7f41c55873e0c310c4e36b0901a39bf88d92a7748a7a46baa000f386a0d154c05 SHA512 391d6b0981b4332fd074a568d33838cbd5d71e7200a3a7ba27bc96641d12be4a6452def0bb615a54e1fa6d1f1f6863a39d56cf3e503aba42ea0d0fdddbbb9102
DIST astroid-2.5.3.tar.gz 317721 BLAKE2B 66566287fa65489064056d6dba65fd7c59cbe9e4e3d88ba5a33d08dbcf6af48b6f1eb4aafb4f7483a1fc0eb6fdd92a7bc8f1991d05cd4d589fbcc6ed6f5db769 SHA512 dbf480e86023f7d093386cc68b259d5b721717638927a893b3ade0a397b212f5f24a17c753b705cf499b47e12ab255d51126b41b5af167d5c3018f5aade1abcb
DIST astroid-2.5.5.tar.gz 344997 BLAKE2B 9ab06834ac05557c095efaaf348772d5d523cb5f0fc79f369319d7b15a92a6737d8464ad8a331474737bab9453519cb779dbb1bb5bbe6ab2ee8bb9a0af269c47 SHA512 ffaa6b156c6bdb3399581388bdb4d058e0182b42051c83752d2f93fdf6aafe28e26bd085d272c9ae2907978ba22a94713e959df70b891f772ffe7f891a1f0dd3
+DIST astroid-2.5.6.tar.gz 345014 BLAKE2B 13916663aef712449a842e50b74ecd2e1b82817e1c128fdf9a4d5779d391deab7f806300cb6597b29920222ff041b13eb985aa395dff024af6fee628a84f883f SHA512 3d10d0f92c4b4c2d7d5e0035f23ae554b512f34ddd55b4c1c4032b328643dfe60cb4aa675a3824423fcd12baea7961847435f1894a47fafa99802f3e17a5605f
DIST astroid-2.5.tar.gz 304788 BLAKE2B 3d9304dcfff72aa8172fe88b5ee53b723b47b3e602b7c30cae15a61d0cff7d578ccfde4885b56c09c8254ca3fe185fcf297bf85184d68798eb51f1860c516db6 SHA512 eba7e757a12f89a74bff579731a157fda3c8d8dd1b5a4369791d47f7f6e321b23e167260d0988d389428222c8c98929e66ad26f379ff937e274dcd1abdb3b3d2
diff --git a/dev-python/astroid/astroid-2.5.6.ebuild b/dev-python/astroid/astroid-2.5.6.ebuild
new file mode 100644
index 000000000000..a1a4c659cf62
--- /dev/null
+++ b/dev-python/astroid/astroid-2.5.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/PyCQA/astroid/
+ https://pypi.org/project/astroid/"
+SRC_URI="
+ https://github.com/PyCQA/astroid/archive/${P}.tar.gz"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Version specified in __pkginfo__.py.
+RDEPEND="
+ >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.11.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
+ ' python3_7)"
+BDEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # no clue why it's broken
+ tests/unittest_modutils.py::GetModulePartTest::test_knownValues_get_builtin_module_part
+ )
+
+ # Faker causes sys.path_importer_cache keys to be overwritten
+ # with PosixPaths
+ epytest -p no:faker ${deselect[@]/#/--deselect }
+}