summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-08-11 20:11:13 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-08-11 20:14:15 -0400
commit3b8f3b0fd28d4a5b21cd830472f1878d1b4cac42 (patch)
tree2d31156e50358944ba8c9f2408bc039ccda59845
parentprofiles: move www-client/chromium[system-icu] mask to 17.0 profile (diff)
downloadgentoo-3b8f3b0fd28d4a5b21cd830472f1878d1b4cac42.tar.gz
gentoo-3b8f3b0fd28d4a5b21cd830472f1878d1b4cac42.tar.bz2
gentoo-3b8f3b0fd28d4a5b21cd830472f1878d1b4cac42.zip
dev-python/construct: remove spurious test dependencies
tox and pytest-cov are not actually needed to run tests. Package-Manager: Portage-2.3.44, Repoman-2.3.10
-rw-r--r--dev-python/construct/construct-2.8.21.ebuild4
1 files changed, 1 insertions, 3 deletions
diff --git a/dev-python/construct/construct-2.8.21.ebuild b/dev-python/construct/construct-2.8.21.ebuild
index be8e7c29cc9d..a856d066558a 100644
--- a/dev-python/construct/construct-2.8.21.ebuild
+++ b/dev-python/construct/construct-2.8.21.ebuild
@@ -18,10 +18,8 @@ IUSE="test"
DEPEND="test? (
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/tox[${PYTHON_USEDEP}]
)"
python_test() {
- py.test -vv || die "Tests failed under ${EPYTHON}"
+ pytest -vv || die "Tests failed under ${EPYTHON}"
}