summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-01-04 00:39:45 +0200
committerMart Raudsepp <leio@gentoo.org>2020-01-04 00:48:14 +0200
commit3ba0cdea3eae7b69ade6cdc94066754d562e5785 (patch)
tree1f77b308b86210212c4ff74946fa305a84fc1901
parentapp-portage/repoman: Remove old versions (diff)
downloadgentoo-3ba0cdea3eae7b69ade6cdc94066754d562e5785.tar.gz
gentoo-3ba0cdea3eae7b69ade6cdc94066754d562e5785.tar.bz2
gentoo-3ba0cdea3eae7b69ade6cdc94066754d562e5785.zip
net-libs/webkit-gtk: Unconditionally build WebGL with enabled OpenGL
Building with ENABLE_GL but without WEBGL is unsupported upstream and has no real benefits. The WebGL support can be disabled at runtime, if desired. Therefore tie the choice of WebGL support to having enabled GL support (full opengl or gles2), matching what upstream does if an explicit ENABLE_WEBGL _private_ configuration value isn't given. We keep it as a separately passed arg for now just for the sake of being explicit. WebGL has been fine without gstreamer for a while now - that seems to have been a temporary bug in the ancient 2.10 series - so all this does not mean that gstreamer is required with GL and the REQUIRED_USE that was there is dropped (not only due to IUSE=webgl going away - had it stayed, the restriction was wrong with USE=webgl being there too). It should also be fine without libXcomposite and libXdamage on wayland-only builds, so those deps are simply dropped (they are still there for USE=X). This may have been a reason some may have wanted to disable WebGL for wayland-only builds, but it was probably legacy wrong deps. Update a comment about WebRTC (upstream is using libwebrtc instead of OpenWebRTC right now, but isn't a supported build option out of tarballs, plus it may end up using gstreamer instead before it becomes non-experimental). Also remove outdated comment about FTL_JIT (it doesn't need llvm anymore and we are letting it be handled automatically by upstream cmake per-architecture conditionals). Drop -fno-strict-aliasing build flags forcing - upstream build system is supposed to take care of it these days. As I confirmed I still get it in the compiler calls, this change does not necessitate a revbump either (the rest are --changed-use territory). Closes: https://bugs.gentoo.org/704538 Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.26.2.ebuild17
1 files changed, 3 insertions, 14 deletions
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.26.2.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.26.2.ebuild
index b743a3359c96..24b670605874 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.26.2.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.26.2.ebuild
@@ -18,15 +18,12 @@ LICENSE="LGPL-2+ BSD"
SLOT="4/37" # soname version of libwebkit2gtk-4.0
KEYWORDS="amd64"
-IUSE="aqua coverage doc +egl +geolocation gles2-only gnome-keyring +gstreamer +introspection +jpeg2k +jumbo-build libnotify +opengl seccomp spell wayland +webgl +X"
+IUSE="aqua coverage doc +egl +geolocation gles2-only gnome-keyring +gstreamer +introspection +jpeg2k +jumbo-build libnotify +opengl seccomp spell wayland +X"
-# webgl needs gstreamer, bug #560612
# gstreamer with opengl/gles2 needs egl
REQUIRED_USE="
gles2-only? ( egl !opengl )
gstreamer? ( opengl? ( egl ) )
- webgl? ( gstreamer
- || ( gles2-only opengl ) )
wayland? ( egl )
|| ( aqua wayland X )
"
@@ -38,7 +35,7 @@ RESTRICT="test"
# Aqua support in gtk3 is untested
# Dependencies found at Source/cmake/OptionsGTK.cmake
# Various compile-time optionals for gtk+-3.22.0 - ensure it
-# Missing OpenWebRTC checks and conditionals, but ENABLE_MEDIA_STREAM/ENABLE_WEB_RTC is experimental upstream (PRIVATE OFF)
+# Missing WebRTC support, but ENABLE_MEDIA_STREAM/ENABLE_WEB_RTC is experimental upstream (PRIVATE OFF) and shouldn't be used yet in 2.26
# >=gst-plugins-opus-1.14.4-r1 for opusparse (required by MSE)
wpe_depend="
>=gui-libs/libwpe-1.3.0:1.0
@@ -93,9 +90,6 @@ RDEPEND="
opengl? ( ${wpe_depend} )
gles2-only? ( ${wpe_depend} )
)
- webgl? (
- x11-libs/libXcomposite
- x11-libs/libXdamage )
seccomp? (
>=sys-apps/bubblewrap-0.3.1
@@ -205,9 +199,6 @@ src_configure() {
# append-ldflags "-Wl,--reduce-memory-overheads"
# fi
- # Multiple rendering bugs on youtube, github, etc without this, bug #547224
- append-flags $(test-flags -fno-strict-aliasing)
-
# Ruby situation is a bit complicated. See bug 513888
local rubyimpl
local ruby_interpreter=""
@@ -223,8 +214,6 @@ src_configure() {
# TODO: Check Web Audio support
# should somehow let user select between them?
#
- # FTL_JIT requires llvm
- #
# opengl needs to be explicetly handled, bug #576634
local use_wpe_renderer=OFF
@@ -254,11 +243,11 @@ src_configure() {
-DENABLE_SPELLCHECK=$(usex spell)
-DENABLE_WAYLAND_TARGET=$(usex wayland)
-DUSE_WPE_RENDERER=${use_wpe_renderer} # WPE renderer is used to implement accelerated compositing under wayland
- -DENABLE_WEBGL=$(usex webgl)
$(cmake-utils_use_find_package egl EGL)
$(cmake-utils_use_find_package opengl OpenGL)
-DENABLE_X11_TARGET=$(usex X)
-DENABLE_OPENGL=${opengl_enabled}
+ -DENABLE_WEBGL=${opengl_enabled}
-DENABLE_BUBBLEWRAP_SANDBOX=$(usex seccomp)
-DBWRAP_EXECUTABLE="${EPREFIX}"/usr/bin/bwrap # If bubblewrap[suid] then portage makes it go-r and cmake find_program fails with that
-DCMAKE_BUILD_TYPE=Release