summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-25 05:05:13 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-25 05:42:55 +0100
commit3bbd0b8c064e64476f0dfca339b4cfa65e8e6479 (patch)
tree8cbd0d245a1cb46e0eba750dfa3c21d0b039a7a1
parentdev-python/boto3: Bump to 1.34.27 (diff)
downloadgentoo-3bbd0b8c064e64476f0dfca339b4cfa65e8e6479.tar.gz
gentoo-3bbd0b8c064e64476f0dfca339b4cfa65e8e6479.tar.bz2
gentoo-3bbd0b8c064e64476f0dfca339b4cfa65e8e6479.zip
app-admin/awscli: Bump to 1.32.27
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.32.27.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 7c406d070da0..605f25e6bd76 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.32.18.gh.tar.gz 2626034 BLAKE2B 3d60094c5b6e70f8df57ada95e269cb71
DIST aws-cli-1.32.23.gh.tar.gz 2627296 BLAKE2B b85f77efb7e7f9fac19fc342bcef44def80de24ec7ce50157fc06b0db6c3e0726c21ffcd13861d11170745d76e15e8f54d4d3ec030b4dea93d882b31a9aa38b2 SHA512 b566af885a980a74e159bd41ec4dbb94af87a5a43f4c07845c98ce60762bf33f2770c46a290f95102819da7266bb59040fbb4c7d92422c32f6e1a0b7bfa6f5cf
DIST aws-cli-1.32.25.gh.tar.gz 2628727 BLAKE2B a7058ac75a3c2952c03f0a70faf87b53587c108b28109114c66a5232a4a59f856ee7a49c8058a6b8d08ddfebdf86f5bc6a79fd43a4397663c75163013fb50608 SHA512 68882310a1cb2202522ffb559e9ae5e72fcff0dd5bcd130a2df2df0698e510e05d9763f618c506d1c3990b51cbde9f6186633b4cfb970f799994b43da0f03946
DIST aws-cli-1.32.26.gh.tar.gz 2629020 BLAKE2B 4e493e46ee004bf97be65733f28382a81f737ee30182e22328c20e48e9cd1106ca391c98d18b883739520d73089602d1a4c559e6af4b61ea4d5ea4157e9f1081 SHA512 1f02c53517593ced7ab18d71b6d5eab6fd68673169032b6540acb3675c413aa6047cdbf427d595c2bf4df8eb9575d3455a50be3c7906d06bafa12e627781469a
+DIST aws-cli-1.32.27.gh.tar.gz 2629131 BLAKE2B cd29f4fae8ef9bdc39bb2737649123ddc65195eef642ca511a9de5c0f8530833efa8bbd8da0ca14dded088fe8ed662a058188aea2fba290f88a1f0c89a678fb4 SHA512 68af10e6beadf7454dfbed51d78ed5792b22b9a7755019b300f64c6a5c9bf7dd1be1649f5cea1d2368811d2b5b18cd8bdb511c18b67f4775c37717ce9bd5d3ee
diff --git a/app-admin/awscli/awscli-1.32.27.ebuild b/app-admin/awscli/awscli-1.32.27.ebuild
new file mode 100644
index 000000000000..18c949df1583
--- /dev/null
+++ b/app-admin/awscli/awscli-1.32.27.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}