summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-01 09:28:37 +0000
committerSam James <sam@gentoo.org>2021-02-01 10:20:21 +0000
commit3bbec67e236f6c9ec66ed4db42a2b2628a88bc2a (patch)
treeff13b24d609695311f1e295e8cbce03294c55a6c
parentnet-libs/libprotoident: cleanup old (diff)
downloadgentoo-3bbec67e.tar.gz
gentoo-3bbec67e.tar.bz2
gentoo-3bbec67e.zip
net-libs/net6: port to EAPI 7
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-libs/net6/net6-1.3.14-r2.ebuild29
1 files changed, 18 insertions, 11 deletions
diff --git a/net-libs/net6/net6-1.3.14-r2.ebuild b/net-libs/net6/net6-1.3.14-r2.ebuild
index 7d269bc823c0..cb41c438fc5d 100644
--- a/net-libs/net6/net6-1.3.14-r2.ebuild
+++ b/net-libs/net6/net6-1.3.14-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils flag-o-matic ltprune multilib
+inherit flag-o-matic
DESCRIPTION="Network access framework for IPv4/IPv6 written in C++"
HOMEPAGE="http://gobby.0x539.de/"
@@ -12,13 +12,17 @@ SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ~arm ~hppa ppc x86"
-IUSE="nls static-libs"
+IUSE="nls"
-RDEPEND="dev-libs/libsigc++:2
- >=net-libs/gnutls-1.2.10"
-DEPEND="${RDEPEND}
+BDEPEND="
virtual/pkgconfig
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="
+ dev-libs/libsigc++:2
+ >=net-libs/gnutls-1.2.10:=
+"
+DEPEND="${RDEPEND}"
DOCS=( AUTHORS ChangeLog NEWS README )
PATCHES=(
@@ -27,11 +31,14 @@ PATCHES=(
src_configure() {
append-cxxflags -std=c++11
- econf $(use_enable nls) \
- $(use_enable static-libs static)
+
+ econf \
+ --disable-static \
+ $(use_enable nls)
}
src_install() {
default
- prune_libtool_files
+
+ find "${ED}" -name '*.la' -delete || die
}