summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-15 11:19:44 +0300
committerJohn Helmert III <ajak@gentoo.org>2022-09-01 12:45:18 -0500
commit3be5ebc85d013c7390db32d6fc5f10a88a127f30 (patch)
tree7412986c80207bd141b3b3d4e1c450ba4265c152
parentnet-wireless/gnuradio: add gr-iio blocker (diff)
downloadgentoo-3be5ebc85d013c7390db32d6fc5f10a88a127f30.tar.gz
gentoo-3be5ebc85d013c7390db32d6fc5f10a88a127f30.tar.bz2
gentoo-3be5ebc85d013c7390db32d6fc5f10a88a127f30.zip
media-video/tsmuxer: update to new version
Updated to opensourced (license is Apache-2.0) version available at https://github.com/justdan96/tsMuxer Resolved multiple vulnerabilities (CVE-2021-26805, CVE-2021-34067, CVE-2021-34068, CVE-2021-34069, CVE-2021-34070, CVE-2021-34071, CVE-2021-35344, CVE-2021-35346, CVE-2021-45860, CVE-2021-45861, CVE-2021-45863, CVE-2021-45864) Closes: https://bugs.gentoo.org/691814 Bug: https://bugs.gentoo.org/783519 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: John Helmert III <ajak@gentoo.org>
-rw-r--r--media-video/tsmuxer/Manifest1
-rw-r--r--media-video/tsmuxer/metadata.xml3
-rw-r--r--media-video/tsmuxer/tsmuxer-2.6.16_p20220706.ebuild40
3 files changed, 44 insertions, 0 deletions
diff --git a/media-video/tsmuxer/Manifest b/media-video/tsmuxer/Manifest
index 602c43239fed..2ccc03ae6c61 100644
--- a/media-video/tsmuxer/Manifest
+++ b/media-video/tsmuxer/Manifest
@@ -1 +1,2 @@
DIST tsmuxer-2.6.11.tar.gz 538798 BLAKE2B 18f5f9002e356664ae84343afbadcddd447743404bcdcca709ba039ebb2ab05e5fba7eda0f30c86c29e18040d646004d1aec7dec34ed008ddbdb15228c63f09d SHA512 25b552153b76231ac1b88858d2178564d22edd18c6b08dc872765ac214ca6fd1ff6df5c5fff0f24647ea35f3f990e364bfb8adff5dd79c69cc12875fafb4f137
+DIST tsmuxer-2.6.16_p20220706.tar.gz 699612 BLAKE2B 101f97b0846a1051c7920878c304e62d6e4d42a3c85c0d1e0fe8cd7cf2ebfd49ad0c75966c0b5e171a6e878d19ff6a03481b29bac4d0b1994285c24893597349 SHA512 96ffaf04a02a0f7cc643a49b54d299648bff551aa03263547d17abeb7871cdb867d98d13becea6e69d1d5691afffc9011ce502a3e7e9bd78f5025bff79d3ad76
diff --git a/media-video/tsmuxer/metadata.xml b/media-video/tsmuxer/metadata.xml
index 3f59174a7177..5cb1a1ccb7e0 100644
--- a/media-video/tsmuxer/metadata.xml
+++ b/media-video/tsmuxer/metadata.xml
@@ -11,4 +11,7 @@
Dune HD Ultra, Sony Playstation3 and others). tsMuxeR is a part of
SmartCONTENT, content preparation solution.
</longdescription>
+ <upstream>
+ <remote-id type="github">justdan96/tsMuxer</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/media-video/tsmuxer/tsmuxer-2.6.16_p20220706.ebuild b/media-video/tsmuxer/tsmuxer-2.6.16_p20220706.ebuild
new file mode 100644
index 000000000000..963a534a2470
--- /dev/null
+++ b/media-video/tsmuxer/tsmuxer-2.6.16_p20220706.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+COMMIT="fafc3cd747457906290df773063ad8022684a33a"
+MY_PN="tsMuxer"
+
+DESCRIPTION="Utility to create and demux TS and M2TS files"
+HOMEPAGE="https://github.com/justdan96/tsMuxer"
+SRC_URI="https://github.com/justdan96/${MY_PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt5"
+
+BDEPEND="virtual/pkgconfig
+ qt5? ( dev-qt/linguist-tools:5 )"
+DEPEND="qt5? (
+ dev-qt/qtmultimedia:5
+ dev-qt/qtwidgets:5
+ )
+ media-libs/freetype
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${COMMIT}"
+
+DOCS=( README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DTSMUXER_STATIC_BUILD=OFF
+ -DTSMUXER_GUI=$(usex qt5)
+ )
+ cmake_src_configure
+}