summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-09-30 07:54:39 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-09-30 07:54:56 +0100
commit3be65bd024ba4873caf192d056c8017870806f0d (patch)
tree5bbcd2575fe9fe751e344bfef61ea8c4dc9bad84
parentmedia-gfx/imagemagick: Inline PN in mirror, to make it greppable (diff)
downloadgentoo-3be65bd0.tar.gz
gentoo-3be65bd0.tar.bz2
gentoo-3be65bd0.zip
dev-haskell/citeproc-hs: convert IUSE underscore to dash
Reported-by: Michał Górny Closes: https://bugs.gentoo.org/695052 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-haskell/citeproc-hs/citeproc-hs-0.3.10-r1.ebuild14
-rw-r--r--dev-haskell/citeproc-hs/citeproc-hs-0.3.10.ebuild51
-rw-r--r--dev-haskell/citeproc-hs/metadata.xml6
3 files changed, 10 insertions, 61 deletions
diff --git a/dev-haskell/citeproc-hs/citeproc-hs-0.3.10-r1.ebuild b/dev-haskell/citeproc-hs/citeproc-hs-0.3.10-r1.ebuild
index 1c7f1a2bf920..113ca2b6418e 100644
--- a/dev-haskell/citeproc-hs/citeproc-hs-0.3.10-r1.ebuild
+++ b/dev-haskell/citeproc-hs/citeproc-hs-0.3.10-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,7 +15,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="+bibutils embed_data_files +hexpat +network +small_base unicode_collation"
+IUSE="+bibutils embed-data-files +hexpat +network +small-base unicode-collation"
RDEPEND="dev-haskell/json:=[profile?]
dev-haskell/mtl:=[profile?]
@@ -25,13 +25,13 @@ RDEPEND="dev-haskell/json:=[profile?]
dev-haskell/utf8-string:=[profile?]
>=dev-lang/ghc-7.4.1:=
bibutils? ( >=dev-haskell/hs-bibutils-0.3:=[profile?] )
- embed_data_files? ( dev-haskell/file-embed:=[profile?] )
+ embed-data-files? ( dev-haskell/file-embed:=[profile?] )
hexpat? ( >=dev-haskell/hexpat-0.20.2:=[profile?] )
!hexpat? ( dev-haskell/xml:=[profile?] )
network? ( >=dev-haskell/http-4000.0.9:=[profile?]
>=dev-haskell/network-2.6:=[profile?]
>=dev-haskell/network-uri-2.6:=[profile?] )
- unicode_collation? ( dev-haskell/text:=[profile?]
+ unicode-collation? ( dev-haskell/text:=[profile?]
dev-haskell/text-icu:=[profile?] )
"
DEPEND="${RDEPEND}
@@ -46,9 +46,9 @@ src_prepare() {
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag bibutils bibutils) \
- $(cabal_flag embed_data_files embed_data_files) \
+ $(cabal_flag embed-data-files embed_data_files) \
$(cabal_flag hexpat hexpat) \
$(cabal_flag network network) \
- $(cabal_flag small_base small_base) \
- $(cabal_flag unicode_collation unicode_collation)
+ $(cabal_flag small-base small_base) \
+ $(cabal_flag unicode-collation unicode_collation)
}
diff --git a/dev-haskell/citeproc-hs/citeproc-hs-0.3.10.ebuild b/dev-haskell/citeproc-hs/citeproc-hs-0.3.10.ebuild
deleted file mode 100644
index 5765a67367bb..000000000000
--- a/dev-haskell/citeproc-hs/citeproc-hs-0.3.10.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.3
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit base haskell-cabal
-
-DESCRIPTION="A Citation Style Language implementation in Haskell"
-HOMEPAGE="http://istitutocolli.org/repos/citeproc-hs/"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+bibutils embed_data_files +hexpat +network +small_base unicode_collation"
-
-RDEPEND="dev-haskell/json:=[profile?]
- dev-haskell/mtl:=[profile?]
- >=dev-haskell/pandoc-types-1.8:=[profile?] <dev-haskell/pandoc-types-1.13:=[profile?]
- dev-haskell/parsec:=[profile?]
- dev-haskell/syb:=[profile?]
- dev-haskell/utf8-string:=[profile?]
- >=dev-lang/ghc-7.4.1:=
- bibutils? ( >=dev-haskell/hs-bibutils-0.3:=[profile?] )
- embed_data_files? ( dev-haskell/file-embed:=[profile?] )
- hexpat? ( >=dev-haskell/hexpat-0.20.2:=[profile?] )
- !hexpat? ( dev-haskell/xml:=[profile?] )
- network? ( >=dev-haskell/http-4000.0.9:=[profile?]
- >=dev-haskell/network-2.6:=[profile?]
- >=dev-haskell/network-uri-2.6:=[profile?] )
- unicode_collation? ( dev-haskell/text:=[profile?]
- dev-haskell/text-icu:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6
-"
-
-PATCHES=("${FILESDIR}/${P}-ghc-7.10.patch")
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag bibutils bibutils) \
- $(cabal_flag embed_data_files embed_data_files) \
- $(cabal_flag hexpat hexpat) \
- $(cabal_flag network network) \
- $(cabal_flag small_base small_base) \
- $(cabal_flag unicode_collation unicode_collation)
-}
diff --git a/dev-haskell/citeproc-hs/metadata.xml b/dev-haskell/citeproc-hs/metadata.xml
index a27651833e76..9c951e54db57 100644
--- a/dev-haskell/citeproc-hs/metadata.xml
+++ b/dev-haskell/citeproc-hs/metadata.xml
@@ -7,11 +7,11 @@
</maintainer>
<use>
<flag name="bibutils">use Chris Putnam's <pkg>app-text/bibutils</pkg></flag>
- <flag name="embed_data_files">Embed locale files into the library (needed for windows packaging)</flag>
+ <flag name="embed-data-files">Embed locale files into the library (needed for windows packaging)</flag>
<flag name="network">use <pkg>dev-haskell/network</pkg> and <pkg>dev-haskell/http</pkg> to retrieve CSL file from URIs</flag>
<flag name="hexpat">use <pkg>dev-haskell/hexpat</pkg> instead of <pkg>dev-haskell/xml</pkg> for XML parsing</flag>
- <flag name="small_base">Choose the new smaller, split-up base package.</flag>
- <flag name="unicode_collation">Use Haskell bindings to the <pkg>dev-libs/icu</pkg></flag>
+ <flag name="small-base">Choose the new smaller, split-up base package.</flag>
+ <flag name="unicode-collation">Use Haskell bindings to the <pkg>dev-libs/icu</pkg></flag>
</use>
<longdescription>
citeproc-hs is a library for rendering