summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-03 00:31:08 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-03 00:31:23 -0500
commit3be703df1d0f9649d26d53f2d241321820ed3b3b (patch)
tree3a50dd40315c72e38cf7882edcd6584f38c9c2e2
parentdev-php/pecl-stomp: new revisions fixing the no-ssl build. (diff)
downloadgentoo-3be703df.tar.gz
gentoo-3be703df.tar.bz2
gentoo-3be703df.zip
dev-php/pecl-redis: new version 3.1.0 supporting php-7.1.
Gentoo-Bug: 601688 Package-Manager: portage-2.3.0
-rw-r--r--dev-php/pecl-redis/Manifest1
-rw-r--r--dev-php/pecl-redis/pecl-redis-3.1.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-php/pecl-redis/Manifest b/dev-php/pecl-redis/Manifest
index f0667e461f33..005c7f9c8381 100644
--- a/dev-php/pecl-redis/Manifest
+++ b/dev-php/pecl-redis/Manifest
@@ -1,3 +1,4 @@
DIST redis-2.2.7.tgz 134340 SHA256 95e5331cd7e709771eb4479c455bcf326a74b2aea3b1a5cba00b4c95e66dc902 SHA512 88be2abeda62b7c1c95b6d399bbb5f97774d956001b4d13a8e5f183e86fe6336d91f479a8125adcaeff1ad5617a920953961360fc3484ebafc3ed915bcd7f86c WHIRLPOOL e7c8ea7c0c4578933211d4571d742ad09eadb5dd93e207d4f0d5858bfacb7a78eb4bd7ed34cafbc17b465b0d423ea0ff788dee907d89c4939ee4a9acbbe8b95d
DIST redis-2.2.8.tgz 192131 SHA256 fc533752de62848f645707b65cba9d015ab4ed9c7a978c7bd710a5934d97b1b5 SHA512 a0b536dd75934797ee89d21c5a907ee730f5887a8d4cc09c70f3190b7c950f34febf3745d7263ad1fb23adb8b60b7eaf7943514dc0c05553c2b2a620277abfbf WHIRLPOOL 5e9c94e030a0918d7b9bdaf16a2e9434539720d593239d2e46b6a197bc41e12d5d2561ae33908471c1b00dce0980cb64295da0c92e4a587bc0ffef66e12c921b
DIST redis-3.0.0.tgz 189720 SHA256 de0e349027ea0821fbfb7f1961226223f3179bb84c6dada515f0145227993f70 SHA512 0dc4a6363e6bcefdbb50abec500558aaf709ca4e418d11dcebc15509684c81c5286781003725346d7ff748d8b4eea9735cdc82dc9c37fa54c8e7009f6e8bc494 WHIRLPOOL fa612b130ff6611425a4a7e3bb85c40148c006627fce04cd3fd1efcbdbe4780bb3cd3cdb2483d9c385eadf3ba97b82ffd43c906611dd8b5f03b4272a0e24bc4e
+DIST redis-3.1.0.tgz 197322 SHA256 886c9650815184fb11478a3f3f7a1f1519ed89496ed9fcac47520f01851b8b3e SHA512 b8692ac1b21cb66c1239129a3c539d6235f48ab14675c0fe00a7be5ae40f0b650518466f8619494e6a897fa212262d30de3acb528958c70417fb5280c20d1931 WHIRLPOOL fa7fc0763991d27606dd6cf43db2d2cdfeb8ede59384b20819af41dcf46e985778cc8ee840656979e9c58a93202d4665b40c2aa333f179dae6129c90bc16d914
diff --git a/dev-php/pecl-redis/pecl-redis-3.1.0.ebuild b/dev-php/pecl-redis/pecl-redis-3.1.0.ebuild
new file mode 100644
index 000000000000..6a7daed4c74d
--- /dev/null
+++ b/dev-php/pecl-redis/pecl-redis-3.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PHP_EXT_NAME="redis"
+USE_PHP="php5-6 php7-0 php7-1"
+DOCS=( arrays.markdown README.markdown )
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="PHP extension for interfacing with Redis"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="igbinary"
+
+DEPEND="igbinary? (
+ php_targets_php5-6? ( dev-php/igbinary[php_targets_php5-6] )
+ php_targets_php7-0? ( dev-php/igbinary[php_targets_php7-0] )
+ php_targets_php7-1? ( dev-php/igbinary[php_targets_php7-1] ) )"
+RDEPEND="${DEPEND}"
+
+# The test suite requires network access.
+RESTRICT=test
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-redis
+ $(use_enable igbinary redis-igbinary)
+ )
+ php-ext-source-r3_src_configure
+}
+
+src_test(){
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ # Run tests for Redis class
+ ${PHPCLI} -d extension=modules/redis.so \
+ tests/TestRedis.php \
+ --class Redis \
+ --host ${PECL_REDIS_HOST} || die 'test suite failed'
+ done
+}