summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2023-09-08 23:31:03 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-14 20:56:21 +0300
commit3beac7e2ecca4cc16d0cf4f4af527faa22eb8b5a (patch)
tree186f311ef2a5112fe51eedfb1058194d232d3818
parentnet-misc/nextcloud-client: Stabilize 3.9.1 amd64, #914186 (diff)
downloadgentoo-3beac7e2ecca4cc16d0cf4f4af527faa22eb8b5a.tar.gz
gentoo-3beac7e2ecca4cc16d0cf4f4af527faa22eb8b5a.tar.bz2
gentoo-3beac7e2ecca4cc16d0cf4f4af527faa22eb8b5a.zip
media-gfx/pqiv: add 2.12
Update to EAPI 8, cleanup src_configure() phase, add missing dependencies. Closes: https://bugs.gentoo.org/800242 Closes: https://bugs.gentoo.org/836072 Closes: https://bugs.gentoo.org/856511 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--media-gfx/pqiv/Manifest1
-rw-r--r--media-gfx/pqiv/pqiv-2.12.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/media-gfx/pqiv/Manifest b/media-gfx/pqiv/Manifest
index 541250778a45..f33f0d89e3ec 100644
--- a/media-gfx/pqiv/Manifest
+++ b/media-gfx/pqiv/Manifest
@@ -1 +1,2 @@
DIST pqiv-2.11.tar.gz 139825 BLAKE2B 981d472ccd3284b2e9ad3da8e84233c95555a927af797f8421ac820225d3d39cab2275f01269a986bab54994e0fce2095b7c33b1201e7a6117e1c8399617341b SHA512 6017a9d7ed332915a9f6fa788bb02c3b9d4d83c2ae2f9a8ab7d7738caa14ba3e9d253906f2e73fdfd368bb5e7bc51380ee9906fd9921e5f7f113811fd3da66f7
+DIST pqiv-2.12.tar.gz 141927 BLAKE2B b33f14c78422dc53f9d97eb6277da0ad51ae5d9ecd60497a879ab6057206c7cd695d6242e76f33856467c7821beac3e6d13ea3dda7aa4d4142e7682384ee8d63 SHA512 f921d7949c9d229536188e9652cc687dcc55127875f329d0a64e6e2a55ea1a6827c0df6925685ae923ba1a000fbf2d2dc1dd825e67a12815a49b2cb703ea2e2f
diff --git a/media-gfx/pqiv/pqiv-2.12.ebuild b/media-gfx/pqiv/pqiv-2.12.ebuild
new file mode 100644
index 000000000000..f3ab04fd650e
--- /dev/null
+++ b/media-gfx/pqiv/pqiv-2.12.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo linux-info toolchain-funcs xdg
+
+DESCRIPTION="A powerful GTK 3 based command-line image viewer with a minimal UI"
+HOMEPAGE="https://github.com/phillipberndt/pqiv http://www.pberndt.com/Programme/Linux/pqiv/"
+SRC_URI="https://github.com/phillipberndt/pqiv/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="archive ffmpeg imagemagick pdf postscript webp"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/cairo-1.6
+ >=x11-libs/gdk-pixbuf-2.2:2
+ x11-libs/gtk+:3
+ >=x11-libs/pango-1.10
+ archive? ( app-arch/libarchive:0= )
+ ffmpeg? ( media-video/ffmpeg:0= )
+ imagemagick? ( media-gfx/imagemagick:0= )
+ pdf? ( app-text/poppler:0= )
+ postscript? ( app-text/libspectre:0= )
+ webp? ( media-libs/libwebp:0= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~INOTIFY_USER"
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ local backends=(
+ "gdkpixbuf"
+ $(usex archive "archive" "")
+ $(usex archive "archive_cbx" "")
+ $(usex ffmpeg "libav" "")
+ $(usex imagemagick "wand" "")
+ $(usex pdf "poppler" "")
+ $(usex postscript "spectre" "")
+ $(usex webp "webp" "")
+ )
+ local myconf=(
+ --backends-build=shared
+ --backends=$(printf "%s," "${backends[@]}")
+ --prefix="${EPREFIX}/usr"
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ )
+ edo ./configure "${myconf[@]}"
+}
+
+src_compile() {
+ tc-export CC
+ emake VERBOSE=1 CFLAGS="${CFLAGS}"
+}