summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-16 15:52:51 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-16 15:56:10 +0200
commit3c04b7346a50f6191bbc01288d811ed00d86ef55 (patch)
treea2337d185e0c1ca9e826f0418f255a686b14b94f
parentdev-python/jupyter-events: Bump to 0.8.0 (diff)
downloadgentoo-3c04b7346a50f6191bbc01288d811ed00d86ef55.tar.gz
gentoo-3c04b7346a50f6191bbc01288d811ed00d86ef55.tar.bz2
gentoo-3c04b7346a50f6191bbc01288d811ed00d86ef55.zip
dev-python/jupyter-server: Bump to 2.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyter-server/Manifest1
-rw-r--r--dev-python/jupyter-server/jupyter-server-2.8.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/jupyter-server/Manifest b/dev-python/jupyter-server/Manifest
index c8b9b99e07ba..c70ce5c8c839 100644
--- a/dev-python/jupyter-server/Manifest
+++ b/dev-python/jupyter-server/Manifest
@@ -2,3 +2,4 @@ DIST jupyter_server-2.5.0.tar.gz 694029 BLAKE2B bea1082709653617c812124378e1e2a6
DIST jupyter_server-2.7.0.tar.gz 704548 BLAKE2B d328b3254143191627d3f743a2ceb1ef16216e04db714ee75bb7e0002c3cb238b8ec7c7f06599ebb1e9a0b000dcb00c7844bc2c894f450bdf3e99d209dbb9106 SHA512 e8d9ec3b65b25844fbd8e5353a6d1899c07d83ce446c70cae563652b35761d8cbba5d9f5dd52c390e8294dddd70710383e615a7ca07f5e6836ec69708496eb7c
DIST jupyter_server-2.7.2.tar.gz 705360 BLAKE2B fc896756caccacba82a65dbaf68f2e2e3dac816e22360b0a24b495fb54958925b85b71be2fbd552654fd5d588739b42ad18495b4ff1df3ac7628fa6d7a970a98 SHA512 ea3b968a742c47e90451e4d701801895ec16304705d65d48609a803934a77143ccff21de697aef061c1e0b9829c122ace0d1d9bdd5889bebbb58a9e6cda35e1f
DIST jupyter_server-2.7.3.tar.gz 705798 BLAKE2B d5655968f17b2a5536539858769124650f41985d5d99b782e70d99140a7e61820b913b525fc10041a56b6946ec4feb7e05015a10970786d024628e8c840fae94 SHA512 ad9be38208ef4196417561355a62889e34d657f3114b710f13f974f4b453b465b7d473ced46eba873ee980d631d2648e0d4b29267011ed444247a33325f959e9
+DIST jupyter_server-2.8.0.tar.gz 708394 BLAKE2B 2beaba510b0e841203c58316db8507c8c503fdeacfbe7de1287d1ecf0740334c02b430ad7111043e21da45669cc1bd13bb313b5cd45f999490fa07c9057b1bea SHA512 e2ec60994737a9979545aaba3de1f846eb68c809cb952bfba6ce22c061f1e644a712f4b7b069ebfc393e8dd7a7bf723b2c3530a7a1b103eb1dbf42a60a59e6e6
diff --git a/dev-python/jupyter-server/jupyter-server-2.8.0.ebuild b/dev-python/jupyter-server/jupyter-server-2.8.0.ebuild
new file mode 100644
index 000000000000..319926686a1c
--- /dev/null
+++ b/dev-python/jupyter-server/jupyter-server-2.8.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core services, APIs, and REST endpoints to Jupyter web applications"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/jupyter_server/
+ https://pypi.org/project/jupyter-server/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~x86"
+
+RDEPEND="
+ >=dev-python/anyio-3.1.0[${PYTHON_USEDEP}]
+ dev-python/argon2-cffi[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-7.4.4[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-5.1.0[${PYTHON_USEDEP}]
+ dev-python/jupyter-server-terminals[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-events-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/nbconvert-6.4.4[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3.0[${PYTHON_USEDEP}]
+ dev-python/overrides[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/prometheus-client[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-24[${PYTHON_USEDEP}]
+ >=dev-python/send2trash-1.8.2[${PYTHON_USEDEP}]
+ >=dev-python/terminado-0.8.3[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.6.0[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+
+"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # This fails if your terminal is zsh (and maybe other non-bash as well?)
+ tests/test_terminal.py
+ # Fails because above is ignored
+ tests/auth/test_authorizer.py
+ # Fails with additional extensions installed
+ tests/extension/test_app.py::test_stop_extension
+)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.1-skip-npm.patch"
+)
+
+python_test() {
+ # FIXME: tests seem to be affected by previously installed version
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest \
+ -p pytest_tornasync.plugin \
+ -p jupyter_server.pytest_plugin \
+ -p pytest_console_scripts \
+ -p pytest_timeout
+}