summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2019-12-27 14:45:13 +0100
committerAaron Bauman <bman@gentoo.org>2019-12-28 21:42:47 -0500
commit3c0f37faa071da4f7c26a0b13658c5f2a0819f5b (patch)
tree89710adfbe4aaef2796f66881a3822b1c99f541f
parentdev-python/pathtools: Add python3_{7,8} (diff)
downloadgentoo-3c0f37fa.tar.gz
gentoo-3c0f37fa.tar.bz2
gentoo-3c0f37fa.zip
dev-python/watchdog: Add python3_7
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Package-Manager: Portage-2.3.84, Repoman-2.3.20 Closes: https://github.com/gentoo/gentoo/pull/14013 Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--dev-python/watchdog/watchdog-0.9.0.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/dev-python/watchdog/watchdog-0.9.0.ebuild b/dev-python/watchdog/watchdog-0.9.0.ebuild
index 4dbe580e9f7c..e5d5a062db72 100644
--- a/dev-python/watchdog/watchdog-0.9.0.ebuild
+++ b/dev-python/watchdog/watchdog-0.9.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6} pypy)
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy)
inherit distutils-r1 eutils
@@ -15,27 +15,21 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
IUSE="test"
-RESTRICT="!test? ( test )"
CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
RDEPEND="${CDEPEND}
dev-python/argh[${PYTHON_USEDEP}]
dev-python/pathtools[${PYTHON_USEDEP}]"
DEPEND="${CDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
- )"
+ test? ( >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
src_prepare() {
default
rm tox.ini || die
}
-python_test() {
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}
-
pkg_postinst() {
optfeature "Bash completion" dev-python/argcomplete
}