summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-30 06:49:24 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-30 07:02:33 +0200
commit3c14087e55f1d00c6118973b9059a0b5984f6711 (patch)
treeca1065e32148612f729f22232e217aafd29c2d96
parentdev-python/paho-mqtt: Bump to 2.1.0 (diff)
downloadgentoo-3c14087e55f1d00c6118973b9059a0b5984f6711.tar.gz
gentoo-3c14087e55f1d00c6118973b9059a0b5984f6711.tar.bz2
gentoo-3c14087e55f1d00c6118973b9059a0b5984f6711.zip
dev-python/truststore: Bump to 0.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/truststore/Manifest1
-rw-r--r--dev-python/truststore/truststore-0.9.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/truststore/Manifest b/dev-python/truststore/Manifest
index edeba996d29d..075305b4e52d 100644
--- a/dev-python/truststore/Manifest
+++ b/dev-python/truststore/Manifest
@@ -1 +1,2 @@
DIST truststore-0.8.0.gh.tar.gz 25619 BLAKE2B 3c1beeea036274349e31ea45741e2cdfb84f468a3073dcb67618cb4907831a83aac90f774c7a0309c35b5c303e490a56ed0623ae1b3d5ba4189a2ffefd05f56f SHA512 9492874b2c0eb5ba011c0d4af6fc4e2d1664686458775344c928e25248b0d54f776d9400138330b225146402345ab8d5ccb9f73b5db51e566342855a8b4ac579
+DIST truststore-0.9.0.gh.tar.gz 26618 BLAKE2B f3d26a863e2810f620bc565eb819f8c113d9746f30869d2d7c1310f317b846f97525d7437fcf511ffaa28b622112604426f4e02655cbe5af1096b0c19dd39ece SHA512 b0af8bb3688c387c521b722c84ce7b5660238d7919eca76dd60f3dfe3bd6484c6e005125975b326eae2824a96120693536f8047980feae4c3aaed443870705ea
diff --git a/dev-python/truststore/truststore-0.9.0.ebuild b/dev-python/truststore/truststore-0.9.0.ebuild
new file mode 100644
index 000000000000..6f5193f91dbe
--- /dev/null
+++ b/dev-python/truststore/truststore-0.9.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Verify certificates using native system trust stores"
+HOMEPAGE="
+ https://github.com/sethmlarson/truststore/
+ https://pypi.org/project/truststore/
+"
+SRC_URI="
+ https://github.com/sethmlarson/truststore/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+# The vast majority of tests require Internet access.
+PROPERTIES="test_network"
+RESTRICT="test"
+
+BDEPEND="
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p pytest_httpserver
+}