summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2023-03-24 14:27:34 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2023-03-24 14:27:46 -0700
commit3c1566b838cd1e03c11581a4c3d21a3fe3cfbf50 (patch)
treecb7a6262d79c1b15cf0bd1d5f7f711993ce8d5d7
parentsys-devel/rust-std: add 1.68.1 (diff)
downloadgentoo-3c1566b838cd1e03c11581a4c3d21a3fe3cfbf50.tar.gz
gentoo-3c1566b838cd1e03c11581a4c3d21a3fe3cfbf50.tar.bz2
gentoo-3c1566b838cd1e03c11581a4c3d21a3fe3cfbf50.zip
sys-devel/rust-std: drop 1.59.0
Closes: https://bugs.gentoo.org/897296 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--sys-devel/rust-std/Manifest3
-rw-r--r--sys-devel/rust-std/rust-std-1.59.0.ebuild155
2 files changed, 1 insertions, 157 deletions
diff --git a/sys-devel/rust-std/Manifest b/sys-devel/rust-std/Manifest
index 5ef3cbdd1ab9..f799160e0e0f 100644
--- a/sys-devel/rust-std/Manifest
+++ b/sys-devel/rust-std/Manifest
@@ -1,2 +1 @@
-DIST rustc-1.59.0-src.tar.xz 128942756 BLAKE2B b28114f14c9a0fec7db56fde79a985360fd8438c3b14eede49ed12e540c2636be960d0fd800c569af193886ac76fe8bf604d5dae59214ae08cb0cc6cc0ca404e SHA512 acace866871d13a55d365f65d7e15c192c3cd33096862571df6317e066b7474d668b95ae281e0244967778c05f1e33966c3c55616218bd25d3770a2b2d4f0365
-DIST rustc-1.68.0-src.tar.xz 147856584 BLAKE2B ee835ab2edc65c8f889d8d9e3e76e86ba87ba66ceb8ab6682b198b43d5587740b6c666a502e41f6fb075bae7a1f85d04c8b39e27a9d9af3b2beeccdf6e2039aa SHA512 f6cc5c06488080f2d7ce8c4f5adf7ca8ae8b10caea627b57876b051593af1201a48823d0abf5fcbcd344b46606b53957569db9844d647a5fdc4abca06e260f3a
+DIST rustc-1.68.1-src.tar.xz 147834548 BLAKE2B 98e02c1ff3ed37cd52d1f348331ffe007583f078fbd1bc581eb32a098eee816f301cd833ecf9f806b8e0c673aa963b34d2e357c089bdb59a8a7464ab46b18307 SHA512 cf3921bc260db54b0f3afc0e6bc9fe8d560ddb81de5d2d4496746307d42a8010291f119d0cfc463996efce6ef829a0494b4eb6145e21c94fd113ff51ee010e21
diff --git a/sys-devel/rust-std/rust-std-1.59.0.ebuild b/sys-devel/rust-std/rust-std-1.59.0.ebuild
deleted file mode 100644
index eeb0b3f1fe49..000000000000
--- a/sys-devel/rust-std/rust-std-1.59.0.ebuild
+++ /dev/null
@@ -1,155 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit flag-o-matic multiprocessing python-any-r1 rust-toolchain toolchain-funcs
-
-DESCRIPTION="Rust standard library, standalone (for crossdev)"
-HOMEPAGE="https://www.rust-lang.org"
-SRC_URI="https://static.rust-lang.org/dist/rustc-${PV}-src.tar.xz"
-
-LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
-SLOT="stable/$(ver_cut 1-2)"
-# please do not keyword
-#KEYWORDS="" #nowarn
-IUSE="debug"
-
-BDEPEND="
- ${PYTHON_DEPS}
- ~dev-lang/rust-${PV}:=
-"
-
-DEPEND="||
- (
- >="${CATEGORY}"/gcc-4.7:*
- >="${CATEGORY}"/clang-3.5:*
- )
-"
-
-RDEPEND="${DEPEND}"
-
-# need full compiler to run tests
-RESTRICT="test"
-
-QA_FLAGS_IGNORED="usr/lib/rust/${PV}/rustlib/.*/lib/lib.*.so"
-
-S="${WORKDIR}/${P/-std/c}-src"
-
-#
-# The cross magic
-#
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-is_cross() {
- [[ ${CHOST} != ${CTARGET} ]]
-}
-
-toml_usex() {
- usex "$1" true false
-}
-
-pkg_pretend() {
- is_cross || die "${PN} should only be used for cross"
-}
-
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- default
-}
-
-src_configure() {
- # do the great cleanup
- strip-flags
- filter-flags '-mcpu=*' '-march=*' '-mtune=*' '-m32' '-m64'
- strip-unsupported-flags
-
- local rust_root x
- rust_root="$(rustc --print sysroot)"
- rtarget="$(rust_abi ${CTARGET})"
- rtarget="${ERUST_STD_RTARGET:-${rtarget}}" # some targets need to be custom.
- rbuild="$(rust_abi ${CBUILD})"
- rhost="$(rust_abi ${CHOST})"
-
- echo
- for x in CATEGORY rust_root rbuild rhost rtarget RUSTFLAGS CFLAGS CXXFLAGS LDFLAGS; do
- einfo "$(printf '%10s' ${x^^}:) ${!x}"
- done
-
- cat <<- EOF > "${S}"/config.toml
- [build]
- build = "${rbuild}"
- host = ["${rhost}"]
- target = ["${rtarget}"]
- cargo = "${rust_root}/bin/cargo"
- rustc = "${rust_root}/bin/rustc"
- submodules = false
- python = "${EPYTHON}"
- locked-deps = true
- vendor = true
- extended = true
- verbose = 2
- cargo-native-static = false
- [install]
- prefix = "${EPREFIX}/usr/lib/${PN}/${PV}"
- sysconfdir = "etc"
- docdir = "share/doc/rust"
- bindir = "bin"
- libdir = "lib"
- mandir = "share/man"
- [rust]
- # https://github.com/rust-lang/rust/issues/54872
- codegen-units-std = 1
- optimize = true
- debug = $(toml_usex debug)
- debug-assertions = $(toml_usex debug)
- debuginfo-level-rustc = 0
- backtrace = true
- incremental = false
- default-linker = "$(tc-getCC)"
- rpath = false
- dist-src = false
- remap-debuginfo = true
- jemalloc = false
- [dist]
- src-tarball = false
- [target.${rtarget}]
- ar = "$(tc-getAR ${CTARGET})"
- cc = "$(tc-getCC ${CTARGET})"
- cxx = "$(tc-getCXX ${CTARGET})"
- linker = "$(tc-getCC ${CTARGET})"
- ranlib = "$(tc-getRANLIB ${CTARGET})"
- $(usev elibc_musl 'crt-static = false')
- EOF
-
- einfo "${PN^} configured with the following settings:"
- cat "${S}"/config.toml || die
-}
-
-src_compile() {
- env RUST_BACKTRACE=1 \
- "${EPYTHON}" ./x.py build -vv --config="${S}"/config.toml -j$(makeopts_jobs) \
- library/std --stage 0 || die
-}
-
-src_test() {
- ewarn "${PN} can't run tests"
-}
-
-src_install() {
- local rustlib="lib/rust/${PV}/lib/rustlib"
- dodir "/usr/${rustlib}"
- pushd "build/${rhost}/stage0-sysroot/lib/rustlib" > /dev/null || die
- cp -pPRv "${rtarget}" "${ED}/usr/${rustlib}" || die
- popd > /dev/null || die
-}