summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-11-27 13:57:55 -0800
committerMatt Turner <mattst88@gentoo.org>2018-11-27 14:00:18 -0800
commit3c29c176a31e5035e065c515ffc072639be7df4a (patch)
tree1419a3ce1d3b80cd1c43b057e8188f2a66a7f9df
parentdev-cpp/waylandpp: x86 stable (bug #671966) (diff)
downloadgentoo-3c29c176.tar.gz
gentoo-3c29c176.tar.bz2
gentoo-3c29c176.zip
dev-libs/wayland-protocols: Version bump to 1.17
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.17.ebuild43
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-9999.ebuild2
3 files changed, 45 insertions, 1 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index 4ff11acf0ad5..f43a6a7ddc05 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -2,3 +2,4 @@ DIST wayland-protocols-1.13.tar.xz 99680 BLAKE2B 6bb0ecf08e6b0950c50ba40cffc07d7
DIST wayland-protocols-1.14.tar.xz 99844 BLAKE2B 55298d24dbaa6cce017775313e9f4cfccbf3176d7ef24c786f1384111a274c3a0164ac753ebfb4e708094199105cc32ccb58cdb22711e0e0711441dde45883bb SHA512 78d2b47c462618ece0c9c19f250b28efb39436e715f624205c7705dbbae4f125ff2eafa2454e7dce527d3b13449dcb037b282bbbb9ea9d9f52809d6b8187a204
DIST wayland-protocols-1.15.tar.xz 100816 BLAKE2B 22ab7291a4554345a40858d1051e4842ddf1b4442e4a5446f1d8ef4202c8e71307daec5a9a1cca18e7134329367063509286f85b40d9bfda52276945c5b799f2 SHA512 4a3dcd8f3219f3c43fb2399b33626a579d4fbfb94298fd5a831946e7eadfcc0538b6732f71cbc7ac2c2896362821efd5ac6b1392071b831fa80eb7b2f48845b3
DIST wayland-protocols-1.16.tar.xz 104156 BLAKE2B 7c6403e5498c2a9f1a97dfeef780a8df0bd05287e8866619657b29f5fc79c82fcc0892a7099b5eda80720dd136f8fa3c848c05aaf870e978e09ab2b04d883c2b SHA512 8ab33021854f3e8f6bca7a9e69427e7a3e53297cc0abd4c006de7e55fac66da3ad88489a6eb4e6c28c7ba2addd96e7f055309f3c8918643b18ef78a4fb637f84
+DIST wayland-protocols-1.17.tar.xz 107680 BLAKE2B cde978ceeaa9d71ac76cd007c511011fed6a110e772a6a9e880a5fd07a0318239a11235aac25b855d0f7ed5ae9980dd2103886092e85a92ed606c8a2f53de726 SHA512 5f3aacbba58717092036659d9b665dc10ff05ee51df61b1de38b22f0417285a74fd8a6d15ca049ad60d204f28203aa13d773c52140c7c02db2c498a6964c2643
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.17.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.17.ebuild
new file mode 100644
index 000000000000..0b33125e7a05
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.17.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/wayland/wayland-protocols.git"
+ EXPERIMENTAL="true"
+
+ inherit git-r3 autotools
+else
+ inherit autotools
+fi
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ $PV != 9999* ]]; then
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/wayland"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ default
+}
diff --git a/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild b/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
index 4948be07ff86..0b33125e7a05 100644
--- a/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
+++ b/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6