summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-31 16:29:10 +0100
committerMichał Górny <mgorny@gentoo.org>2022-10-31 16:49:18 +0100
commit3c33b1848ef0d1a4b3595646d795aca898560ca5 (patch)
tree7d43935eeeba315e56db803b3097e28b0c778d17
parentdev-python/pytest-metadata: Bump to 2.0.4 (diff)
downloadgentoo-3c33b184.tar.gz
gentoo-3c33b184.tar.bz2
gentoo-3c33b184.zip
dev-python/pyrsistent: Bump to 0.19.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyrsistent/Manifest1
-rw-r--r--dev-python/pyrsistent/pyrsistent-0.19.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyrsistent/Manifest b/dev-python/pyrsistent/Manifest
index adb357a8ba40..4a8658980f52 100644
--- a/dev-python/pyrsistent/Manifest
+++ b/dev-python/pyrsistent/Manifest
@@ -1 +1,2 @@
DIST pyrsistent-0.18.1.tar.gz 100522 BLAKE2B 75632d254993666076a68d81b8b5a7aced8601146fed5cd63f1d56c5e0578650a197aca7630855de32a8447eab972203aa7d83009398f96e6f374c0a4b2cc1ba SHA512 353ad6e9165e1afdde37730a9289cf8dde28491abb688d702a8c8f5279e24f5ce387a5d00ac4a077322299f9c1a535781bcacdcd1cb914ddb317b3ca9641778b
+DIST pyrsistent-0.19.1.tar.gz 102135 BLAKE2B 02756ae7c6172b2ee383508f896ae01ee4abc71b68b6b7135d08422959ef4a821f8e7464547d8a65802d0cac5663ff98d6102870f86fcb37d86d2ea7fa7e871f SHA512 d7bf09298f2713b3e741a02f34efeb0d083f5ff85d7c19e3c7a13e5051d3e0e120f2831190595a764722fe733ba8e105f820c833b5c59638e92eb4c14604e788
diff --git a/dev-python/pyrsistent/pyrsistent-0.19.1.ebuild b/dev-python/pyrsistent/pyrsistent-0.19.1.ebuild
new file mode 100644
index 000000000000..7a4e9ef1fc6d
--- /dev/null
+++ b/dev-python/pyrsistent/pyrsistent-0.19.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Persistent/Functional/Immutable data structures"
+HOMEPAGE="
+ https://github.com/tobgu/pyrsistent/
+ https://pypi.org/project/pyrsistent/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest