summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2021-07-08 12:48:31 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-07-08 12:49:09 +0300
commit3c56f061b5d7eaf320fb28a6004ea70aea017586 (patch)
treee011029b3f46175ee5527b7c3a758ae572156c64
parentsys-libs/lwp: EAPI7, ltprune-- (diff)
downloadgentoo-3c56f061.tar.gz
gentoo-3c56f061.tar.bz2
gentoo-3c56f061.zip
net-p2p/mktorrent: bump snapshot versionm, respect CC
Bug: https://bugs.gentoo.org/717032 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-p2p/mktorrent/Manifest1
-rw-r--r--net-p2p/mktorrent/mktorrent-1.1_p20210130.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/net-p2p/mktorrent/Manifest b/net-p2p/mktorrent/Manifest
index 6751181ee26b..f8ab0acc15a9 100644
--- a/net-p2p/mktorrent/Manifest
+++ b/net-p2p/mktorrent/Manifest
@@ -1 +1,2 @@
DIST mktorrent-4c221a05d949a3767a2671de139c6014909daf6b.tar.gz 24574 BLAKE2B e7dcc17aca52c8d1f9d816ce3e89bea5c2b1d7759dba6a00578960b253652506b7e61855d769440056aaa6b0719e6856108ca5b80977152746a648862c71e97b SHA512 49ba2697373a1b40829d50d66faaaeb57fa3893e97283ec2844b447b8e4cf2713d7c0e76e49d3893475f5ce298c3215249751defe0f952d2c52df1bf68f7706c
+DIST mktorrent-de7d011b35458de1472665f50b96c9cf6c303f39.tar.gz 27939 BLAKE2B 3fbf2c98829be21394b6517f2548925fdc83c9199a209aed39a6ba5f31174e34a3290b8c01eaf55e13acd2f15100cf9ecb20073d5fa9d4d1e3b2fb7641f3418d SHA512 4194d73958ba0d43e88a167c46a24e2a92e94b43682f96079a7317fb77f9e48477eddc1556a9785e5c7e5e1745efa7679d1b6b2b41c0ba2aa6df9dae4d3eb489
diff --git a/net-p2p/mktorrent/mktorrent-1.1_p20210130.ebuild b/net-p2p/mktorrent/mktorrent-1.1_p20210130.ebuild
new file mode 100644
index 000000000000..5de284de9187
--- /dev/null
+++ b/net-p2p/mktorrent/mktorrent-1.1_p20210130.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Simple command line utility to create BitTorrent metainfo files"
+HOMEPAGE="https://github.com/pobrn/mktorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pobrn/mktorrent"
+else
+ COMMIT_ID="de7d011b35458de1472665f50b96c9cf6c303f39"
+ SRC_URI="https://github.com/pobrn/${PN}/archive/${COMMIT_ID}.tar.gz -> ${PN}-${COMMIT_ID}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT_ID}"
+fi
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="threads +ssl debug"
+
+RDEPEND="
+ ssl? ( dev-libs/openssl:0= )
+"
+
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ tc-export CC
+
+ local myemakeargs=(
+ USE_LARGE_FILES=1
+ DEBUG=$(usex debug)
+ USE_OPENSSL=$(usex ssl)
+ USE_PTHREADS=$(usex threads)
+ )
+ emake "${myemakeargs[@]}"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}